Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ESPN Snowboarding sub-menu hang
#1
Hi, I'm new, hope this is the right subforum, etc...

So I am trying to run ESPN Winter X-Games: Snowboarding and I can't get past the menus. The wiki page had nothing in it but a screenshot so I started with all default settings and the only adjustment so far that's had any positive effect is the Skip MPEG Hack (without it, videos before the title screen did not load, but were black screens that I had to manually skip with the Start button - no crashes or freezes). Main menu comes up fine, but when I select any sub-menu (other than Options) the sub-menu loads halfway and then hangs (see attached screenshot).

I suspect the cause is video clips that show up in the sub-menus but not the main or options menu. I cannot get these videos to load, or else I cannot get the menus to load without the videos, and Google has not led me to a solution so I'm here.

Here's the relevant log:

Code:
PCSX2 1.4.0-20160105132032- compiled on Jan  5 2016
Savestate version: 0x9a0b0000

Host Machine Init:
    Operating System =  Microsoft Windows 8.1  (build 9600), 64-bit
    Physical RAM     =  8111 MB
    CPU name         =  Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz
    Vendor/Model     =  GenuineIntel (stepping 03)
    CPU speed        =  2.493 ghz (4 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 7fdafbbf
    x86EFlags        =  2c100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins...
    Binding   GS: C:\Users\Benjamin\Documents\emu\PCSX2 1.4\PCSX2 1.4.0\Plugins\gsdx32-avx.dll
Windows 6.3.9600
    Binding  PAD: C:\Users\Benjamin\Documents\emu\PCSX2 1.4\PCSX2 1.4.0\Plugins\lilypad.dll
    Binding SPU2: C:\Users\Benjamin\Documents\emu\PCSX2 1.4\PCSX2 1.4.0\Plugins\spu2-x.dll
    Binding CDVD: C:\Users\Benjamin\Documents\emu\PCSX2 1.4\PCSX2 1.4.0\Plugins\cdvdGigaherz.dll
    Binding  USB: C:\Users\Benjamin\Documents\emu\PCSX2 1.4\PCSX2 1.4.0\Plugins\USBnull.dll
    Binding   FW: C:\Users\Benjamin\Documents\emu\PCSX2 1.4\PCSX2 1.4.0\Plugins\FWnull.dll
(GameDB) 9693 games on record (loaded in 194ms)
    Binding DEV9: C:\Users\Benjamin\Documents\emu\PCSX2 1.4\PCSX2 1.4.0\Plugins\DEV9null.dll
Plugins loaded successfully.

HLE Notice: ELF does not have a path.


Initializing plugins...
    Init GS
Windows 6.3.9600
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
Current Renderer: Direct3D11 (Hardware mode)
    Opening CDVD
isoFile open ok: C:\Users\Benjamin\Documents\PCSX2\ESPN Winter X Games Snowboarding (USA).iso
    Image type  = DVD
 * CDVD Disk Open: DVD, Single layer or unknown:
 * * Track 1: Data (Mode 1) (895680 sectors)
    Opening USB
    Opening FW
    Opening DEV9
McdSlot 0 [File]: C:\Users\Benjamin\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\Benjamin\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v02.00(14/06/2004)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 65.92 fps
# Initialize memory (rev:3.70, ctm:392Mhz, cpuclk:294Mhz detected)

PlayStation 2 ======== Hard reset boot
 ROMGEN=2004-0614, IOP info (CPUID=1f, CACH_CONFIG=0, 2MB, IOP mode)
 <20040614-100909,ROMconf,PS20200AC20040614.bin:11696>
# Total accessable memory size: 32 MB (B:2:8:0) (370:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Feb  6 2003 08:38:48
  CPUID=2e20, BoardID=0, ROMGEN=2004-0614, 32M


IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname rom0:OSDSYS secname all
loadelf version 3.30
Input ELF format filename = rom0:OSDSYS
0 00100000 000586dc ......
Loaded, rom0:OSDSYS
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..
ROM directory not found

PlayStation 2 ======== Update reboot complete
cdvdman Init
rmreset start
rmreset end
clearspu: completed
Pad Driver for OSD (2000/12/05 18:05) 392, 128

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
read/write allocate memory 4000
open name rom0:OSDVER flag 1 data 4a978
open fd = 2
open name rom0:ROMVER flag 1 data 4a978
open fd = 2
open name rom0:XDEV9 flag 1 data 4a978
open fd = 2
loadmodule: fname rom0:XDEV9 args 0 arg
dev9: unknown dev9 hardware.
loadmodule: id 32, ret 1
loadmodule: fname rom0:XDEV9SERV args 0 arg
loadmodule: id -200, ret 1
open name rom0:FONTM flag 1 data 4a978
open fd = 2
open name rom0:FNTIMAGE flag 1 data 4a978
open fd = 2
open name rom0:SNDIMAGE flag 1 data 4a978
open fd = 2
open name rom0:TEXIMAGE flag 1 data 4a978
open fd = 2
open name rom0:ICOIMAGE flag 1 data 4a978
open fd = 2
open name rom0:TZLIST flag 1 data 4a978
open fd = 2
_spu_rev_offsetaddr 1f9021
### addr = 1034255  size = 28640
_spu_rev_offsetaddr 1d9021
### addr = 968719  size = 28640
open name rom0:ROMVER flag 1 data 4a978
open fd = 2
get val add 3c0 type 2 ret 1ff000
get val add 1ff000 type 2 ret 0
open name rom0:PS1ID flag 1 data 4a978
open fd = 2
open name rom0:PS1VERA flag 1 data 4a978
open fd = 2
open name rom1:DVDID flag 1 data 4a978
open fd = -6
ExecutePs2GameDisk
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_200.89;1
(SYSTEM.CNF) Software version = 1.10
(SYSTEM.CNF) Disc region type = NTSC
found 18666 symbols
ELF (cdrom0:\SLUS_200.89;1) Game CRC = 0x5F491DD1, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_200.89;1
(SYSTEM.CNF) Software version = 1.10
(SYSTEM.CNF) Disc region type = NTSC
open name cdrom0:¥SYSTEM.CNF;1 flag 4 data 4a978
open fd = 2
# Restart.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Restart Done.
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname rom0:PS2LOGO secname all
loadelf version 3.30
Input ELF format filename = rom0:PS2LOGO
0 01000000 00019bf0 ..
Loaded, rom0:PS2LOGO
start address 0x1000008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
read/write allocate memory 4000
open name rom0:ROMVER flag 1 data 44078
open fd = 2
loadmodule: fname rom0:OSDSND args 0 arg
loadmodule: id 25, ret 0
_spu_rev_offsetaddr 1dfff1
### addr = 2097120  size = 32
_spu_rev_offsetaddr 1f9021
### addr = 1034255  size = 28640
# Restart.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Restart Done.
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SLUS_200.89;1 secname all
loadelf version 3.30
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_200.89;1
(SYSTEM.CNF) Software version = 1.10
(SYSTEM.CNF) Disc region type = NTSC
Input ELF format filename = cdrom0:¥SLUS_200.89;1
0 00100000 003c9800 .............................................................
Loaded, cdrom0:¥SLUS_200.89;1
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Overall 0 Widescreen hacks loaded
Loading patch '5F491DD1.pnach' from archive 'C:\Users\Benjamin\Documents\emu\PCSX2 1.4\PCSX2 1.4.0\cheats_ws.zip'
comment: Widescreen hack by Arapapa
(Wide Screen Cheats DB) Patches Loaded: 3
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadmodule: fname cdrom0:¥MODULES¥SIO2MAN.IRX args 0 arg
loadmodule: id 25, ret 0
loadmodule: fname cdrom0:¥MODULES¥PADMAN.IRX args 0 arg
loadmodule: id 26, ret 0
loadmodule: fname cdrom0:¥MODULES¥MCMAN.IRX args 0 arg
loadmodule: id 27, ret 0
loadmodule: fname cdrom0:¥MODULES¥MCSERV.IRX args 0 arg
loadmodule: id 28, ret 0
loadmodule: fname cdrom0:¥MODULES¥LIBSD.IRX args 0 arg
loadmodule: id 29, ret 0
loadmodule: fname cdrom0:¥MODULES¥SDRDRV.IRX args 0 arg
sdr driver version 1.4.0 (C)SCEI
 Exit rsd_main
loadmodule: id 30, ret 0
loadmodule: fname cdrom0:¥SOUND¥MAIN.IRX args 0 arg
IOP-Sound Driver module version 0.0.0 (C)KONAMI
 Exit sound_main
Sound Driver Command Loop
loadmodule: id 31, ret 0
QueryMemSize = 200000
QueryTotalFreeMemSize = 145500
Sound Driver Sysytem Initialize
Sound CD Host I/O ¥SOUND¥
CDPOSMAKE
Stream Buffer 1Bank 32768byte 5banks 163840byte used
sceMpegIsEnd pattern found! Recompiling skip video fix...
First Load Start
___SdFirstLoad WAVE0 Start !
 ___SdFirstLoad WAVE0 End  Wave1 Start !
 ___SdFirstLoad WAVE1 End !
 First Load End
Stream Buffer 1Bank 32768byte 5banks 163840byte used
Closing plugins...
    Closing DEV9
    Closing FW
    Closing USB
    Closing CDVD
    Closing SPU2
    Closing PAD
    Closing GS
Plugins closed successfully.
Decommitting host memory for virtual systems...
EE/iR5900-32 Recompiler Reset


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
Download the latest dev build and see if it fixes your issue: https://buildbot.orphis.net/

Also, if you have an Nvidia GPU you should use the OpenGL renderer instead of DX11.
Reply
#3
Can you try 1.5 builds ?
https://buildbot.orphis.net/pcsx2/
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#4
It looks like you have the skipmpeg hack enabled, could be worth disabling that and see if it works any better. On some games that can break things.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
(02-18-2018, 11:31 PM)CK1 Wrote: Download the latest dev build and see if it fixes your issue: https://buildbot.orphis.net/

Also, if you have an Nvidia GPU you should use the OpenGL renderer instead of DX11.

Thanks for the Nvidia tip, complete amateur here.

(02-18-2018, 11:31 PM)lightningterror Wrote: Can you try 1.5 builds ?
https://buildbot.orphis.net/pcsx2/

Tried one build, results below.

(02-18-2018, 11:32 PM)refraction Wrote: It looks like you have the skipmpeg hack enabled, could be worth disabling that and see if it works any better. On some games that can break things.

I've tried with and without skipmpeg and it doesn't seem to have any effect on the sub-menu issue, possibly they don't load far enough for the hack to take effect before hanging?

So, I just tried this build on default settings with OpenGL hardware mode, no hacks and compared it to 1.4 with same settings. 1.5 played the intro videos without a hiccup, but the sub-menus still hang at exactly the same point. Anything else I can try?
Reply
#6
You could try disabling the MTVU hack in the speedhacks tab.
Reply
#7
(02-19-2018, 02:31 AM)CK1 Wrote: You could try disabling the MTVU hack in the speedhacks tab.

I never had it enabled. Also, just tried disabling all the speedhacks, no change.
Reply
#8
Hmm, can you post a screenshot of the emulator window when it freezes? (so that it includes the EE and VU percentages?)
Reply
#9
I would love to, but my internet is acting up and won't let me upload pictures anymore. So I'll write it out:

Code:
Slot: 0 | Speed: 110% (65.80) | Limiter: Normal | GSdx OGL HW | 640x448 | Auto | Interlaced | EE: 47% | GS: 1%

Didn't have a VU %. EE fluctuated between 45-55% and GS was 0-1%.
Reply
#10
Sorry, I forgot. Can you enable MTVU and do a retest (that will give you a VU percentage)
Reply




Users browsing this thread: 1 Guest(s)