Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ecco the Dolphin - SIF Code for loading issue?
#1
Hi guys,

Not normally one to post, but no matter what I searched, I couldn't find an answer to my issue.

Issue is that Ecco the Dolphin DotF gets stuck on loading screen. This looks like a known issue, where one work around was to set EE cyclerates down to -3, but that didn't work for me unfortunately. An earlier solution appeared to be changing some IOP timing in the SIF code, but every time I look for it I can only find people talking about it, but without actually finding the fix.

Does any one know about this? Or failing that, can anyone point me in the general direction to changing SIF code? I have a solid amount of programming experience, so don't need baby instructions, just a general prod in the right direction Smile

Thanks to any who read this!

EDIT: Forgot to post a link explaining where I heard about the SIF code changes.
https://forums.pcsx2.net/Thread-Ecco-the...#pid369642

Posts #6 and 7
Reply

Sponsored links

#2
if you look in sif1.cpp
there's commented out code on line 176, simply uncomment that code and compile, then Ecco should work Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
Thumbs Up 
(07-22-2018, 05:09 PM)refraction Wrote: if you look in sif1.cpp
there's commented out code on line 176, simply uncomment that code and compile, then Ecco should work Smile

Thanks! That's exactly what I needed Smile
Reply
#4
I think the game sometimes works by turning on "enable fast cdvd" option and ee cycle -3 even without altering the sif code.
Reply




Users browsing this thread: 1 Guest(s)