Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Eight Hours Trying to Make This Work... PLEASE Help!
#1
I want to say first and foremost I hope that I am posting this in the correct area and that I'm doing right by creating a thread for it- my apologies if I'm not. Please redirect me and I'll do it correctly, in that case. Anyways, I am not the most tech-savy, and this has been a learning experience and a half for me when it comes to features of the PCSX2 configuration settings because I'm telling you- I HAVE TRIED EVERYTHING I can possibly think of/look up to do.

I'm playing the PS1 Harry Potter and Sorcerer's Stone- and I only have my XBOX 360 controller right now. I've used LilyPad before, and have been able to use my XBOX 360 controller for everything I've done w/ the Emulator.

But now, when I load this game, I'm only able to get through the menus and the starting clips. Once I get to the game starting, I can't move, I can't select square to talk; I'm just stuck right where I start. I went ahead and switched to another game just to make sure it wasn't something that randomly went wrong with my controller itself, granted that game is an actual PS2 game, whereas this is a PS1 game that I'm trying to play (it was my understanding that I could play PS1 games through this Emulator, but just for safety measures I downloaded ePSXe and tried there... with that one, same sort of situation). My controller worked in the other game. I also tried binding just some keyboard keys for basic movement to see if that would help, and it didn't. I cannot for the life of me figure out how to do ANYTHING with ANY controls in this game, and I don't understand why. 

I've toggled through all of the LilyPad configuration settings, set bindings to my controller probably 150 times today, restarted my computer, restarted the Emulator. I've Googled like a madman and looked through all sorts of forums. The ONLY thing I've found that seems to possibly relate to my issue and fix it, is to toggle the "use analog mode if possible" option on the general tab of LilyPad configuration; BUT that's NOT in my LilyPad configuration settings. I'm not sure if it was something taken out with the new version, or what, but that's the only thing I haven't been able to try that might help (or probably won't judging by everything else I've tried... lol).

I've tested both methods of input that I've tried in the General tab of Configuration, and all of the values are registering use from both my controller and my keyboard. So I know they're working.

I'm not sure if there's any images or specs you need to help me, but just let me know and I'll get them for you. Thank you so much in advance to anybody who is able to help me. I'm almost thinking that the solution is just something I'm unable to consider since I'm so inexperienced with this stuff, and in that case I really hope I don't sound too dumb for not knowing. Lol, thank you!!!
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
I'm sorry, I'm trying to understand what you mean. Just copy and paste the full log into a 
Code:
[code]

with brackets? 
Code:
[PCSX2 1.6.0-20200506140834- compiled on May  6 2020
Savestate version: 0x9a0e0000

Host Machine Init:
    Operating System =  Microsoft Windows 10 Home (build 18363), 64-bit
    Physical RAM     =  16263 MB
    CPU name         =  Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz
    Vendor/Model     =  GenuineIntel (stepping 0A)
    CPU speed        =  3.191 ghz (12 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 7ffafbff
    x86EFlags        =  2c100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins from C:\Users\Madison\Desktop\PCSX2\plugins...
    Bound   GS: GSdx32-AVX2.dll [GSdx 20200506140834 (MSVC 19.25 AVX2/AVX2) 1.2.0]
    Bound  PAD: LilyPad.dll [LilyPad (20200506140834) 0.12.1]
    Bound SPU2: Spu2-X.dll [SPU2-X 20200506140834 2.0.0]
    Bound CDVD: cdvdGigaherz.dll [cdvdGigaherz 20200506140834 0.11.0]
    Bound  USB: USBnull.dll [USBnull Driver 20200506140834 0.7.0]
    Bound   FW: FWnull.dll [FWnull Driver 20200506140834 0.7.0]
    Bound DEV9: DEV9null.dll [DEV9null Driver 20200506140834 0.5.0]
Plugins loaded successfully.

(GameDB) 9858 games on record (loaded in 127ms)
HLE Notice: ELF does not have a path.

Initializing plugins...
    Init GS
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Patches: No CRC found, using 00000000 instead.
Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
Current Renderer: Direct3D 11 (Software renderer)
    Opening CDVD
isoFile open ok: C:\Users\Madison\Downloads\PCSX2 GAMES\Games\HPSS Controller Issue Test.iso
    Image type  = CD
* CDVD Disk Open: CD, 1 tracks (1 to 1):
* * Track 1: Data (Mode 1) (256146 sectors)
    Opening USB
    Opening FW
    Opening DEV9
GSdx Lookup CRC:0
McdSlot 0 [File]: C:\Users\Madison\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\Madison\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v01.60(07/02/2002)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
# Initialize memory (rev:3.63, ctm:196Mhz, cpuclk:147Mhz detected)

PlayStation 2 ======== Hard reset boot
ROMGEN=2002-0207, IOP info (CPUID=1f, CACH_CONFIG=0, 2MB, IOP mode)
<20020207-164243,ROMconf,PS20160AC20020207.bin:11552>
# Total accessable memory size: 32 MB (B:2:8:0) (363:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Feb  7 2002 16:41:20
  CPUID=2e20, BoardID=0, ROMGEN=2002-0207, 32M

Patches: No CRC found, using 00000000 instead.
(SYSTEM.CNF) Detected PSX/PSone Disc = cdrom:\SLUS_014.15;1
(SYSTEM.CNF) Detected PSX/PSone Disc = cdrom:\SLUS_014.15;1

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname rom0:OSDSYS secname all
loadelf version 3.30
Input ELF format filename = rom0:OSDSYS
0 00100000 0004c718 .....
Loaded, rom0:OSDSYS
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..
ROM directory not found

PlayStation 2 ======== Update reboot complete
cdvdman Init
rmreset start
rmreset end
clearspu: completed
Pad Driver for OSD (2000/12/05 18:05) 392, 128

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
read/write allocate memory 4000
open name rom0:ROMVER flag 1 data 48a78
open fd = 2
loadmodule: fname rom0:ATAD args 0 arg
ATA: DEV9C version 0x0: unknown device detected
loadmodule: id 31, ret 1
loadmodule: fname rom0:HDDLOAD args 28 arg -osd
loadmodule: id -200, ret 1
open name rom0:FONTM flag 1 data 48a78
open fd = 2
open name rom0:FNTIMAGE flag 1 data 48a78
open fd = 2
open name rom0:SNDIMAGE flag 1 data 48a78
open fd = 2
open name rom0:TEXIMAGE flag 1 data 48a78
open fd = 2
open name rom0:ICOIMAGE flag 1 data 48a78
open fd = 2
open name rom0:TZLIST flag 1 data 48a78
open fd = 2
_spu_rev_offsetaddr 1f9021
### addr = 1034255  size = 28640
_spu_rev_offsetaddr 1d9021
### addr = 968719  size = 28640
open name rom0:ROMVER flag 1 data 48a78
open fd = 2
open name rom1:DVDID flag 1 data 48a78
open fd = -6
(UpdateVSyncRate) Mode Changed to DVD NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
open name cdrom0:¥SYSTEM.CNF;1 flag 2 data 48a78
open fd = 2
# Restart.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Restart Done.
(SYSTEM.CNF) Detected PSX/PSone Disc = cdrom:\SLUS_014.15;1
(SYSTEM.CNF) Detected PSX/PSone Disc = cdrom:\SLUS_014.15;1
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname rom0:PS1DRV secname all
loadelf version 3.30
Input ELF format filename = rom0:PS1DRV
0 00200000 0001bc58 ..
Loaded, rom0:PS1DRV
start address 0x200008
gp address 00000000
loadelf: fname rom0:PS1DRV secname all
loadelf version 3.30
Input ELF format filename = rom0:PS1DRV
0 00200000 0001bc58 ..
Loaded, rom0:PS1DRV
start address 0x200008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
PlayStation Driver Version 1.1.0
[ Make at 17:54:40 Jul 24 2000 ]
read/write allocate memory 4000
open name cdrom0:¥SYSTEM.CNF;1 flag 2 data 44a78
open fd = 2
loadmodule: fname rom0:SIO2MAN args 0 arg
loadmodule: id 25, ret 0
loadmodule: fname rom0:SECRMAN args 0 arg
loadmodule: id 26, ret 1
loadmodule: fname rom0:MCMAN args 0 arg
loadmodule: id 27, ret 0
open name mc0:/BADATA-SYSTEM/TITLE.DB flag 1 data 44a78
open fd = -4
open name mc1:/BADATA-SYSTEM/TITLE.DB flag 1 data 44a78
open fd = -4
eeprom_data[0]:0x00
SLUS_014.15(poly:0, sprt:0, mecha:0, null:0, hl:4, vblank:580, pgpu:4, speial:0, linear:0)
*PCSX2*: go PS1 mode DISC SPEED = 2X

PS-X Realtime Kernel Ver.2.5
Copyright 1993,1994,1998,1999 (C) Sony Computer Entertainment Inc.
KERNEL SETUP!

Configuration : EvCB    0x10            TCB     0x04
System ROM Version 5.0 02/07/02 A
Copyright 1993-1999 (C) Sony Computer Entertainment Inc.
ResetGraph:jtb=8004fc28,env=8004fc70
VSync: timeout
[29 more]
ResetGraph:jtb=8004fc28,env=8004fc70
VSync: timeout
[51 more]
ResetGraph:jtb=8004fc28,env=8004fc70

BOOTSTRAP LOADER Type C Ver 2.1   03-JUL-1994
Copyright 1993,1994 (C) Sony Computer Entertainment Inc.
setup file    : cdrom:SYSTEM.CNF;1
TCB    00000004
EVENT    00000010
STACK    801fff00
BOOT =    cdrom:¥SLUS_014.15;1
argument =    
KERNEL SETUP!

Configuration : EvCB    0x10            TCB     0x04
boot file     : cdrom:¥SLUS_014.15;1
Clear 0x10000 to 0x1ffdd8
EXEC:PC0(00103ddc)  T_ADDR(00100000)  T_SIZE(0000d800)
boot address  : 00103ddc 801fff00
Execute !
                S_ADDR(801fff00)  S_SIZE(00000000)
ResetGraph:jtb=0010c470,env=0010c4b8
VSync: timeout
CD_init:
addr=0010cc2c
ResetGraph:jtb=0010c470,env=0010c4b8
VSync: timeout
Load took 45 vblanks (0.75 seconds)
VSync: timeout
do the -96 stuff
cdrom:¥US.GAM;1    Loaded Failed
Now Execute.....
CD_init:
addr=00070da0
VSync: timeout
ResetGraph:jtb=0006fb4c,env=0006fb94
Running version Oct  2 2001¥16:10:55[special project]
ResetGraph:jtb=0006fb4c,env=0006fb94
VSync: timeout
ResetGraph:jtb=0006fb4c,env=0006fb94
VSync: timeout
ResetGraph:jtb=0006fb4c,env=0006fb94
CD_init:
addr=00070da0
¥MOVIES¥EA.STR;1
VSync: timeout
[32 more]
ResetGraph:jtb=0006fb4c,env=0006fb94
[1 more]
VSync: timeout
SPU:T/O [wait (reset)]
VSync: timeout
[318 more]
SPU:T/O [wait (reset)]
VSync: timeout
[368 more]
SPU:T/O [wait (reset)]
VSync: timeout
[2714 more]
SPU:T/O [wait (reset)]
VSync: timeout]
I hope I interpreted that right. I am so lost with a lot of this stuff. I went ahead and included a file attachment of the Notepad file as well, just in case what I did wasn't right. Thank you!


Attached Files
.txt   emuLogSUPPORT.txt (Size: 9,66 KB / Downloads: 16)
Reply
#4
okay. 1st thing you need to know is that PS1 games support is very limited in pcsx2
That said, if you had the same problem with a real PS1 emulator, the problem may come from your controller itself, or the way you configured it in windows.
try this : https://gamepad-tester.com/ to see if your controller works correctly with windows
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
(01-26-2021, 02:54 PM)jesalvein Wrote: okay. 1st thing you need to know is that PS1 games support is very limited in pcsx2
That said, if you had the same problem with a real PS1 emulator, the problem may come from your controller itself, or the way you configured it in windows.
try this : https://gamepad-tester.com/ to see if your controller works correctly with windows

It's showing all values w/ all buttons, working great. I was thinking the problem might be that it was a PS1 game, which is why I downloaded the ePSXe to check it out. With that one, I can't get past the menu itself, whereas on PCSX2 I can get to the intro clips- but the controller DOES work on the menu screen w/ that one as well. It's just in game after the intro clips that it stops registering.  Huh
Reply
#6
this game probably isn't supported in pcsx2 since PS1 mode is in very early stages

try another PS1 emu, maybe. something like beetlepsx (with retroarch frontend), or duckstation
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
(01-26-2021, 03:35 PM)jesalvein Wrote: this game probably isn't supported in pcsx2 since PS1 mode is in very early stages

try another PS1 emu, maybe. something like beetlepsx (with retroarch frontend), or duckstation

Well.. I downloaded the ePSXe Emulator after a couple hours of fiddling with settings last night. With that one not working, I did not think that a THIRD Emulator would work...

But that's why you're the smart one here, isn't it  Laugh THANK YOU SO MUCH, Duckstation works. Almost 15 hours of my life... saved by a duck. Woo. I FEEL SO SILLY. BUT THANK YOU.  Happy
Reply




Users browsing this thread: 3 Guest(s)