Error: File not found. Path: IsoFileSystem

I am having issues with PCSX2 since I downloaded it. I already knew this emulator for a while now. I used it on my old laptop but since the games were lagging real bad I didn't use it again. I have a new computer now and it should be able to run basically anything, but I can't run any game at all. This is what I did and what happens:

I downloaded PCSX2 from the page itself, version 1.4.0, set all installation to default, didn't touch anything else besides adding the newest Bios files.
After downloading a game to try on (Grand Turismo 2 from *snip*, which is a highly recommended page and I use it constantly to download other games for PS1 for example, never had any ISO issues), I set the emulation to ISO, browse to the ISO extracted file, and click on Run CDVD (Full). 
The window opens for a short second, not loading anything, and then I am left with this message:

File not found.

Path: IsoFileSystem
(pxActionEvent) IsoFS could not find the root directory on the ISO image.(thread:EE Core)

I thought I did some configuration wrong but I didn't modify anything. I tried Run CDVD (Fast), the same message. I tried reinstalling from scratch (even tho I just installed it fresh on a new PC), restarted the PC, nothing. Same message.

I tried downloading various Bios files, tried downloading another game see if that was the issue, I tried moving the ISO file from folder to folder, tried an older version of PCSX2, tried messing around with the Plugins (mostly the emulation ones back and forth), nothing. Same message all over.

I spent over an hour trying to seek a solution on YouTube, Google search, nothing worked. 

I honestly have no idea what is happening.

I might be overlooking some very small detail, but still, I could not find anything that would prevent it from running. In the past, I never messed up with the controls or plugins either, and it worked, slow as hell due to my crappy laptop, but it worked.

Could anyone please help me?

Sponsored links

No. We can't help you.

Quote:After downloading a game to try on

Please read the rules. We don't support piracy.
AMD Ryzen 5 3600 @ 3.60~4.20 GHz | Corsair Vengeance LPX 16 GB (2x8GB) DDR4-3200
MSI GeForce GTX 1660 Super @ 6 GB | Kingston A400 480GB SSD | Windows 10 Pro x64 (b19043.1288)
since it's a PS1 game, it can be , in some way, tolerated.
but this :

Quote:I tried downloading various Bios files,
definitely a no-go
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)