Extreme slowdowns when writing to memory card
Hi everyone, I'm a newbie this is my first post, I hope you guys can help me.

Basically everything was working like a dream then it stopped being so.

I don't think any speed problems I have are due to my hardware (CPU: Intel Core i7-3960X 3.30ghz (has about 1900 STR), graphics card: Nvidia Geforce GTX 1080, RAM: 32 gb, running windows 7 64 bit).

I hadn't used PCSX2 for many years but I got back to it yesterday and I downloaded and installed the newest version.

I kept the default plugins that came with the program and didn't really toy much at all with the configurations.

I have a bunch of PS2 games but my favorite was Soul Calibur III so I played it from the disc and it work wonderfully. I read on the website that it might run even better if I create a ISO from the disc and play that instead so I did that and it worked very well.

The speed was very good and I had no problems with the memory cards. Saving to memory cards and loading from memory cards took seconds. Everything was perfect.

Anyway, I wanted to be a bit fancy and try to get the graphics as good as possible, so I followed a guide I found on google (http://imgur.com/a/PVpip).

In order to get the configuration they were suggesting I had to download the newer version of GSDx. I initially had a lot of trouble in getting it to work because it wouldn't detect my graphics card for some reason so I toyed around with the config.

Anyway, I eventually got it to work and it looked extremely well, HD and all, and the framerate was perfect. No problems with the memory cards either at this point. It ran just as well as if I was playing the actual PS2, except the graphics were much better.

So everything was perfect. Then I shut down PCSX2 for a few hours and played a game on Steam.

When I went back to playing PCSX2, all of a sudden there were problems.

Loading data from the memory card was slower but manageable... but all of a sudden saving to the memory card became a nightmare. The framerate dropped to below 1 and it basically looked like the program crashed and became unresponsive.

I tried restarting the program, but it was the same thing. I tried to let the program save without touching anything and I had to leave the computer running while I watched TV and did other things, and glancing back to my monitor once in a while. It took over 10 minutes to save to the memory card.

The saves are being done, and the data is indeed being saved. But it used to take seconds and now all of a sudden it starts taking forever while the program remains apparently unresponsive. The quickest it's been able to save is about 5 minutes but it's usually 10 or more.

I tried a lot of things. I made new memory cards. I tried 8 gb, 16 gb, 32 gb. I tried with and without NTSF compression. I tried with and without the options "auto-eject memory cards when loading savestates" and "automatically manage saves based on running game." I also tried creating a "folder" memory card which the program says is experimental. I tried to fiddle with the file permissions "clicked 'take ownership' on the memcards folder." I tried to make pcsx2 run in admin mode. I tried to change the priority in task manager. I tried to run the game from the disc instead of the ISO.

No matter what I did, the result was the same: the game was able to save to the memory card, but it took forever, like 10 minutes each time and sometimes even more. Also, when I create a new memory card and format it in the game, the formatting process does the same thing as the saving process - it works, but with an extreme slowdown. Formatting from the playstation menu (when loading with no game) also takes an awful amount of time.

Creating a new memory card is also pretty long... if I click refresh over and over again in windows explorer the .ps2 file can be, say, 200 KB then two or three minutes later it's 800 KB. So it's obviously writing pretty slowly and it takes a while to get to the 8448 KB.

I uninstalled PSCX2 and did a clean re-install to try to have everything just the way it was yesterday when it took seconds. Even with a clean re-install, the problem persisted just the same.

Also, while the game itself still runs well, it runs nowhere near as well as it did yesterday. Yesterday even at the highest graphic settings it was always 60 fps and smooth and it barely ever slowed down at all, even when saving.

It's like if... all of a sudden, with no explanation, the program started having an excruciatingly hard time writing to a memory card or formatting a memory card.

Also, another new thing is whenever I change configurations... when I click OK or Apply it seems to take a very long time to process. I assume the program is writing to an ini file or something. In fact it kind of feels like there's a problem whenever the program attempts to "write" something to a file.

Other programs on my computer run just fine, and the issues with PCSX2 remained the same after a computer reboot.

There aren't any error messages that I can tell in the log. The only thing is that once in a while I get "(FileMcd) Warning: checksum sector overwritten. (1)" Also, whenever I'm saving the log says it auto-ejects and re-inserts the memcard immediately, like this:

[14:45:00.027] Auto-ejecting memcard [port:0, slot:0]

[14:45:00.708] Re-inserting auto-ejected memcard [port:0, slot:0]

Anyway, sorry for the very long post... I would appreciate any help!

Sponsored links

Which version of PCSX2 are you using?

I'm using 1.4.0
Get the latest dev build from here : http://buildbot.orphis.net/pcsx2/

Use the plugin that comes with that instead of changing it. The one you are using is probably highly outdated.
Ok thanks I'll try that
Ok I did a new reinstall from scratch and I tried using the newest build from that page but the problem remains exactly the same Sad
Does it happen in any other game?
The only other game I tried is Valkyrie Profile 2 and it is the same thing
Could you zip up your PCSX2 emulator folder and post it here? Remove the bios from it and any games it might have.
Doesn't make sense at all. PCSX2 should not be causing such issues.

Have you checked the overall performance of the drive it's trying to write to? (Try changing the default folders to another location, preferably a different drive to see if it happens on there too).

If it's not happening on the other drive (assuming you have one to test on) then there's clearly some issue going on with the HDD itself that it tried to read/write to.
AMD Ryzen 5 3600 @ 3.60~4.20 GHz | Corsair Vengeance LPX 32 GB (2x16GB) DDR4-3200
MSI GeForce GTX 1660 Super @ 6 GB | Samsung 980 1TB | Windows 10 Pro x64 (22H2)

Users browsing this thread: 1 Guest(s)