FF X-2 periodic black screen flash
I've been playing FF X-2 (NTSC version) recently and it was running just fine, no slowdown, steady FPS (Average 59.94-60), no blur or ghosting, etc. Then today every 10-20 seconds or so, a black screen flashes across my screen for less than a second. Not sure what the problem is. It's not enough to ruin the game, but it's just noticeable and really annoying.

My emulation settings are set to preset 1 in version 1.0.0 (r5350) of pcsx2, thus frameskipping is turned off. For my video plugin I'm using GSdx9 (hardware) with 1024x1024 resolution, no interlacing with texture filtering, logarithmic Z and alpha correction all turned on. Everything else is default settings.

OS - Windows 7
Processor - Intel Core i7 M620 2.67GHz
RAM - 6 GB
Graphics Card - NVIDIA GeForce GTX 260M

If any other information is needed I can provide it, thanks in advance.

Sponsored links

In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
I'm having this problem as well. I've tried 3 games so far: Okami, FFXII and Rogue Galaxy and it happens in all of them.

I've tried some of the fixes offered in similar threads and unfortunately none of them have worked. The issue is strange, almost like the emulator is blinking, inserting a black frame every 10 seconds or so. I've tried all the interlacing methods and I made sure vsync was off both in pcsx2 and in the nvidia control panel. Disabling aero only changed the flash from black to white. The problem occurs using either Direct3D9 and 11 both in hardware and software modes. I've also tried using the AVX and SSE41 versions of the GSdx plugin.

CPU: i5 3570K
OS: Win7 Home 64bit
PCXS2 version 1.0.0

Okami was played from disc, while FFXII and Rogue Galaxy were both isos. I'm also playing on an LCD tv via HDMI cable if that makes a difference. I do not experience this issue in any other games.

Thanks in advance for any help!
Are you sure that V-Sync and Frameskip is disabled? Had something like this in the past...
Yeah, unfortunately it ain't gonna be that easy.

I made sure vsync is off in both pxsx2 and in the control panel. I also verified frame skipping was off by enabling/disabling in game.

Thanks for the fast reply!
Can you update your card to the latest (secure beta) version and try again? Might be a buggy driver you're using.

Here's a link:

(I'm using this version aswell as we speaking so you are ok, the link is the specific driver for your card)
Drats... that didn't fix it either.

Still, thank you though.
try using 0.9.8 instead of 1.0.0

use directx10 or 11 hardware for the graphics plug in if u can
(10-30-2012, 12:27 PM)solidus Wrote: try using 0.9.8 instead of 1.0.0

use directx10 or 11 hardware for the graphics plug in if u can

Yeah, forgot to mention to use DX10 instead of DX9 since your card supports up to DX10. You will notice some speedup and possibly less bugs.
It's doing it in 0.9.8 as well.

Adding to the mystery, I recently downloaded the dolphin emulator and it's doing it too.
I don't have this problem with any other games or video.

I'm completely stumped.

Users browsing this thread: 1 Guest(s)