FFX: Character attack himself eventhough choose enemy

I start playing FFX again after almost 2 years.
I have encountered this strange bug. Don't know if it's my configuration or not.

In the 2nd battle with Sinspawn where you attack the machine to blow up the bridge, Tidus and Auron keep hitting themselves even though I choose attack enemy command. If I make them attacking themselves, then they will hit the enemies, but then they can't hit the machine.

I have try other configuration, even turn off all hacks and fixes but the problem persists.

I'm using Pcsx2 0.9.8 r4600 on Windows 7 64bit
NVIDIA Geforce GT520M
Intel core i5

Here is the plugins

Emulator Config
No speed hack, no frame skip and Gamefix is set to auto.

Please help me?

Sponsored links

I've gone through that same part without any problems, here's my plugin outlook.

Attached Files Thumbnail(s)
2 years ago when I used Pcsx2 to play FFX, there were no problems with this battle. Also, I have tried switching to the same plugins you use, with different settings but it doesn't work. Perhaps you could tell me in details how you config your plugin?

Might be something with the other config, I am not sure =.=". In the past, this has never happened to me so now I'm clueless.

NOTE: I have added emulator setting in in the 1st post so please take a look.
That is...quite weird.

Try downloading the latest SVN.

After doing so, try using Lilypad instead of TwinPad.

Edit : I can run it just fine with these settings :

I guess it is something between the SVN or Twinpad (probably SVN) or a little bit of both. I downloaded the latest version of SVN and change to Lilypad and now the problem is gone Smile

Thank you for your help. I really appreciate it! Smile

Uhm, probably a bad idea to post another bug in here, but now Tidus can't swim at Baaj temple (still at the beginning of the game after sin attack Zanarkand) =.=". No matter how hard I press the button, he just won't move.
Does the button work in every other scenario? What button is it?

I recommended Lilypad against Twinpad because Twinpad is something I've never heard of and I know the Lilypad is amazing and never gives me problems. As for the SVN...the game has worked for just about everyone else using 0.9.8, but maybe you were a special case somehow.

If you're using an analogue stick to move around and that's what's giving you trouble - try increasing the sensitivity of your movement stick in Lilypad.
Just the direction buttons.
Weird. I seriously don't remember this many bugs when I played this game before.
The direction buttons work just fine before, in the battle (the one I stuck at above), it worked fine because I used it to choose different enemies >.<

ADD: Ah, please never mind, after a few reset, shutdown and restart PCSX2, now they work fine
Weird, really weird.

Again, thanks for the help
You've fully configured Lilypad to run with your controller, right?

If so...I dunno. Maybe try swapping the D-Pad controls with an analogue stick for that one part? Mess with the sensitivity?

I'll let someone else take over from here if nothing works out.
For now everything work fine, I guess mine is a rare case indeed.
I hope no more strange bug for me. I will tweak this and that around if there are anything wrong again.

Thank you Alexander Moore Laugh
You can just call me Alex. I often use my real name to sign up with because I'm so unoriginal Tongue

You're very welcome Smile

Users browsing this thread: 1 Guest(s)