FFX: Graphical issues (Vertical rendering slightly off)
I'm experiencing odd rendering issues in Final Fantasy X. This does happen fairly often, mostly in fight scenes, and some animatic scenes using the in-game renderer, but never when I just 'run around'.

The issue is that the rendered image is 'duplicated' vertically slightly off the original position. E.g. if there's a bit of hair vertically, I see two bits of hair close to each other. Oddly enough, how much it's off varies on the screen. Sometimes all rendering is equally off, and again sometimes the left side may be just fine and the right side way misaligned.

Can anyone give any advice on what may be causing this and how I can fix it?

For the record, I'm using GSdx 3068 (SSE3) 0.1.16, configured to render DX10 with D3D internal res 1800x1200, HW anti aliasing 4. Texture filtering is turned on.

Sponsored links

Could you take a screenshot of the problem?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
(09-12-2010, 09:49 PM)Shadow Lady Wrote: Could you take a screenshot of the problem?

Sure, here's one... It's quite evident, and as I mentioned earlier, this doesn't happen in every fight, but well, perhaps in 70% of them.

[Image: ffxe.jpg]
Deinterlacing option?
It's an effect of the game that just doesn't look so great scaled. Try changing the "UserHacks_SkipDraw = 0" line in the GSdx.ini file to "UserHacks_SkipDraw = 1" (may need higher than 1, not sure) but set it back to 0 for other games.

You can also add a new line "allowHacks = 1" in the GSdx.ini so you can control the skipdraw settings from the GSdx settings in the emulator.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Thanks Shadow Lady, applying those lines in the config file fixed the problem.
Although it's not a bug actually as Shadow Lady stated, it's really accurate emulation. The FFX devs put that blur effect which made the game look nicer on a TV, but when you up the resolution with PCSX2 and everything becomes crystal clear, you get left with a crappy blur effect Tongue
[Image: newsig.jpg]

I am currently experiencing the same issue and the solution listed here is not helping my situation. To be honest it does not seem as if the ini change is doing anything. I changed the ini, exited the app, reloaded and loaded from a save state to test changes but nothing seems affected.

Here is my current setup:
My PC:
Intel i7 920
ATI Radeon 5770

Running PCSX2

My Video Plugin Settings:
Direct3D11 (Hardware)
Interlacing - None
D3D res: 1280 x 1024
Scaling: 4x
Texture Filtering: Yes

Emulation Settings:
EE: Recompiler
IOP: Recompiler
EE Round Mode: Chop/Zero
EE Clamping Mode: Normal
Flush to Zero: Checked
Denormals to Zero: Checked

micro VU Recompiler
micro VU Recompiler
VU Round Mode: Chop/Zero
VU Clamping Mode: Normal
Flush to Zero: Checked
Denormals to Zero: Checked

Base Framerate Adjust: 100%
Slow Motion Adjust: 100%
Turbo Adjust: 200%
NTSC Framerate: 59.94
PAL FrameRate: 60.0
Frame Skipping: Disabled
Frames to Draw: 2
Frames to Skip: 2

GS Window
Standard (4:3)
Custom Window Size: 1143x828
Hide Window on Suspend: checked

Enable Speedhacks: Checked
EE Cyclerate: 1
Enable INTC Spin Detection: Checked
Enable Wait Loop Detection: Checked
Vu Cycle Stealing: 0
mVU Flag Hack: checked

Game Fixes
Enable Game Fixes: Checked
FFX Videos hack: Checked
EE timing hack: Checked

Sorry for the detailed post but i wanted to make sure you had the most info possible.

As a sidenote. changing the allowhacks setting to 1 does not seem to do anything either.

Any help would be greatly appreciated.
Never mind. I think I solved that issue. I had the ini's pointing to the wrong location. All set on that portion. Thanks for the solution.

However...I am still having problems with the text in game. I have tried using the scaling and nothing seems to work to get rid of the lines around the HP and MP. Any thoughts?
You'd have to use "native" or software mode to completely get rid of them but then the 3d wouldn't look so good.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64

Users browsing this thread: 1 Guest(s)