Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFX Slow downs: I am sorry. Please help.
#1
Please, if you are feeling generous, could someone help me with this problem?

I'll be honest. Configuring the emulator is too advanced for me, so I apologize for my ignorance right up front. I haven't a clue what most of those settings do. Even the configuration guide leaves me feeling rather stupid.

I know my computer is old tech, but I can't afford anything better. Based on the following computer specs, is there any reason why I should not be able to play Final Fantasy X without constant slow downs (28fps) from the normal speed (60fps)? It seems like it freezes or maybe it's just the slow down ..... it seems to stutter but that might be due to the slow down as well. If there is no hope, I'll just give up now and thank you for saving me time and frustration.

System Specs (old tech but brand new parts):
CPU: Phenom II X6 3.2GHz 1090T
Video Card: Geforce 9800GT 1GB
RAM: GSkill Ripjaw 8 GB DDR3-1600 (PC3 12800)
Motherboard: Gigabyte model # GA-890FXA-UD5
Windows 7 Ultimate X64.

I am using an ISO that I made myself from the DVD I bought many years ago. (actually I have two copies...bought a second when it was on sale for $20 just to have a backup; would have bought the HD remaster version but my mint condition PS3 was stolen so I have no way to play it now.)

This happened on default settings and when I changed a few things to try to fix it. Since the changes had no positive effect I just put them back to default again. I really don't know what I am doing. Sad

I am using pcsx2-1.2.1-r5875 version of the emulator.

Any other information you need to help troubleshoot?

I would like to have the game looking as beautiful as some folks have been able to accomplish with the PCSX2 emulator, but I would be plenty happy if I could just play the game without issue as long as it looks as good as it did on my PS2. Even if it wasn't as good as that, at the very minimum without the constant slow downs.

I thank you for the valuable time you took to read my request for help and thank you again for any advice you can give on fixing the problem.

Cheers!

Ham08
Reply

Sponsored links

#2
post your pcsx2_vm and gsdx settings (open the ini folder and put contents here. REMOVE personal information from the files like iso directories and bios/plugin list)
Reply
#3
9800gt can handle FFX just fine i not sure about the CPU though as i aviod AMD cpus like plague I know i could play FFX with my old pc which was a 9800gt and intel duo core [email protected] 3ghz just fine at 1080p with 2x msaa that i used back then.

But like said I avoid AMD cpu like the plague and have done so for very long time so I dont know how that compares to the 8400e i had. If it anything like the Athlon X2 my uncle had that I tried to set pcsx2 up on it probably wont work.

Check out the guide in both Saiki and My sig it may help.
Reply
#4
Thank you both for the replies!

contents of PCSX2_vm.ini

Code:
[EmuCore]
CdvdVerboseReads=disabled
CdvdDumpBlocks=disabled
EnablePatches=enabled
EnableCheats=enabled
EnableWideScreenPatches=enabled
ConsoleToStdio=disabled
HostFs=disabled
BackupSavestate=enabled
McdEnableEjection=enabled
MultitapPort0_Enabled=disabled
MultitapPort1_Enabled=disabled
[EmuCore/Speedhacks]
EECycleRate=0
VUCycleSteal=0
fastCDVD=disabled
IntcStat=enabled
WaitLoop=enabled
vuFlagHack=enabled
vuThread=enabled
[EmuCore/CPU]
FPU.DenormalsAreZero=enabled
FPU.FlushToZero=enabled
FPU.Roundmode=1
VU.DenormalsAreZero=enabled
VU.FlushToZero=enabled
VU.Roundmode=0
[EmuCore/CPU/Recompiler]
EnableEE=enabled
EnableIOP=enabled
EnableEECache=disabled
EnableVU0=enabled
EnableVU1=enabled
UseMicroVU0=enabled
UseMicroVU1=enabled
vuOverflow=enabled
vuExtraOverflow=enabled
vuSignOverflow=enabled
vuUnderflow=disabled
fpuOverflow=enabled
fpuExtraOverflow=enabled
fpuFullMode=enabled
StackFrameChecks=disabled
PreBlockCheckEE=disabled
PreBlockCheckIOP=disabled
[EmuCore/GS]
SynchronousMTGS=disabled
DisableOutput=disabled
VsyncQueueSize=2
FrameLimitEnable=enabled
FrameSkipEnable=disabled
VsyncEnable=disabled
ManagedVsync=disabled
LimitScalar=1.00
FramerateNTSC=59.94
FrameratePAL=50.00
DefaultRegionMode=ntsc
FramesToDraw=2
FramesToSkip=2
[EmuCore/Gamefixes]
VuAddSubHack=disabled
VuClipFlagHack=disabled
FpuCompareHack=disabled
FpuMulHack=disabled
FpuNegDivHack=disabled
XgKickHack=disabled
IPUWaitHack=enabled
EETimingHack=disabled
SkipMPEGHack=disabled
OPHFlagHack=disabled
DMABusyHack=disabled
VIFFIFOHack=disabled
VIF1StallHack=disabled
GIFReverseHack=disabled
FMVinSoftwareHack=disabled
[EmuCore/Profiler]
Enabled=disabled
RecBlocks_EE=enabled
RecBlocks_IOP=enabled
RecBlocks_VU0=enabled
RecBlocks_VU1=enabled
[EmuCore/TraceLog]
Enabled=disabled
EE.bitset=0
IOP.bitset=0


contents of GSdx.ini

Code:
[Settings]
Adapter=10DE:0605:0BD219F1:A2
ModeWidth=1024
ModeHeight=768
ModeRefreshRate=60
Renderer=0
Interlace=7
AspectRatio=0
upscale_multiplier=3
windowed=1
filter=2
paltex=0
logz=1
fba=1
aa1=0
nativeres=0
resx=1024
resy=768
extrathreads=0
ShadeBoost=0
Fxaa=0
shaderfx=0
UserHacks=0
ShadeBoost_Contrast=50
ShadeBoost_Brightness=50
ShadeBoost_Saturation=50
UserHacks_MSAA=0
UserHacks_AlphaHack=0
UserHacks_HalfPixelOffset=0
UserHacks_SpriteHack=0
UserHacks_SkipDraw=0
UserHacks_WildHack=0
UserHacks_AggressiveCRC=0
UserHacks_AlphaStencil=0
UserHacks_NVIDIAHack=0
UserHacks_DisableCrcHacks=0
UserHacks_TCOffset=0
Reply
#5
(06-07-2014, 11:23 PM)tsunami2311 Wrote: 9800gt can handle FFX just fine i not sure about the CPU though as i aviod AMD cpus like plague I know i could play FFX wiht 9800gt and intel 8400e duo core just fine at 1080p with 2x msaa that i used back then.

yeah that cpu should handle FFX just fine.




Just go under config>emulation settings> speedhacks and enable MTVU set the EE cycle rate hack to 2.

Under Config>Video>Plugin Settings set renderer to Direct3D10
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#6
maybe also interesting to ask for EE% and GS% during slowdowns.They can be found in the titlebar in windowed mode. But probably what Nobbs said will be sufficient (if the upscaling is not problem).
Reply
#7
(06-07-2014, 11:30 PM)Nobbs66 Wrote: yeah that cpu should handle FFX just fine.




Just go under config>emulation settings> speedhacks and enable MTVU set the EE cycle rate hack to 2.

Under Config>Video>Plugin Settings set renderer to Direct3D10

Thanks for the reply! I tried both of those settings but I still have the same slow down. Any other ideas?
Reply
#8
(06-07-2014, 11:33 PM)willkuer Wrote: maybe also interesting to ask for EE% and GS% during slowdowns.They can be found in the titlebar in windowed mode.
Reply
#9
(06-07-2014, 11:33 PM)willkuer Wrote: maybe also interesting to ask for EE% and GS% during slowdowns.They can be found in the titlebar in windowed mode. But probably what Nobbs said will be sufficient (if the upscaling is not problem).

About 70% and 60%

The percentages were moving pretty fast, so those are approximate give or take.
Reply
#10
was EE ever hitting 99% ?, cause that would indicate cpu bottleneck.

You could try using MTVU hack it may help, If you have allow 8bit textures on turn it off and vis versa
Reply




Users browsing this thread: 1 Guest(s)