FFX cutscene crash
My emulation for Final Fantasy X has been going pretty well until the final cut scene right before getting on the airship. Once I enter the room with the captured summoners the game starts to go nuts, showing geometry and sometimes just random shapes until PCSX2 flat out crashes. I tried running it on GSD SSE41 on both direct x 9, and direct x 10 with both hardware, software and null. I also tried to run it on Zero but that made it even worse.

My Specs is 12gb of ram, a i7 at 2.65 GHz and my graphics card is a radion 5800.

I appreciate any help I can get.

Sponsored links

Tried using the 1888 beta of PCSX2? Can you post your full settings? Are you loading a saved state by chance?
[Image: newsig.jpg]
Just my luck, I tried setting it to x3 frame skip and I managed to get through it.
I had this exact same problem on he same cutscene. Any advice on how to fix it?
Use the latest beta, set the clamps in "Advanced settings" to extra or higher and make sure microVU is disabled in CPU options.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Well, I'm running PCSX, An ISO I ripped, and my system specs are:

OS: Windows Vista SP2
RAM: 1.00GB
Processor: Mobile AMD Athalon 64 4000+ 2.60 GhZ
Graphics card: ATI Mobility Radeon X600

I have played up to the point before fighting the tentacle monster (The first fight in the game) and the cutsceen runs up untill the point Tidus and Auron look off the bridge... Then both Tidus and Auron jump to occupy the same point, and the game still runs, but doesn't advance... Help?

BTW, My settings on PCSX are as follows

EmotinEngine and IOP are on Recompiler
Round mode: Chop/Zero
Clamp Mode: Full
Flush to Zero and Denormals are On.

VU1&VU0 are on Legacy
Round mode: Chop/Zero
Clamp Mode: Extra + Preserve Sign
Flush to Zero and Denormals are On.

EE Cyclerate: 3
VU Cyclestealing: 2
INTC Spin Detection,
Spin loop detection,
MVU flag,
MVU Block are on.


Thank you.

Here's a clip that ends with the glitch.
Disable all speed hacks, set vu and ee clamping to full and extra+preserve sign and load from a memcard not a saved state. If it still fails try remaking your iso with imgburn
[Image: newsig.jpg]
Ah, that is the glitch I've met in FFX PAL-E before. It happens when I'm playing on the PS2, but doesn't when I'm playing on PCSX2. I guess it is a disc problem, since I used an iso with PCSX2, and the disc I used on PS2 is kinda crap. I remember the first time I used that disc, nothing happens. You should try remaking your iso or disc.

Users browsing this thread: 1 Guest(s)