FFXII random screeching sound/high pitched
I've been playing FFXII with all default settings, works very well for my [email protected] and my 260GTX.

However i get random high pitched sounds/screeching which is very annoying. There is no connection when this happens, just running around, fighting, nothing specific.

Any ideas? They game always runs at fullspeed.

i mean the zodiak FFXII version with the fan made english patch btw

Sponsored links

not sure this fan made patch is well emulated.
FFX-2 is quite well emulated as long as you have are using an original game.
this may come from the sound plugin too. Try using spu2x if not done yet.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
It's not FFX-2 it's FFXII (or Final Fantasy 12). The bug is caused by SPU2-X and it seems that disabling timestretch on this plugin takes care of it.
[Image: newsig.jpg]
oh i wasnt aware there is a difference in the numbers - thanks

i will try that out - which i option should i use for sync? off or async mix?
I'd say none, since you get full speed all the time, it isn't needed at all.
[Image: newsig.jpg]
(09-21-2010, 03:02 PM)Bositman Wrote: I'd say none, since you get full speed all the time, it isn't needed at all.

i tried both setting, off and async mix - no changes - still the same annoying screeching sounds - any other ideas?
Try disabling effects. If that fails too, switch to ZeroSPU2.
[Image: newsig.jpg]
TS or at least async mixing should always be on, especially in a game that has CPU load bursts like FF12 Wink

As Bositman said, your best bet is disabling effects (reverb). I'm pretty sure it's that.
disabling timestretch actually fixed the problem, but i seemed to have tested this wrongly before

what i did before was alter a setting and restart the emu, after that i loaded my snapshot and walked around a bit - the screeching was still there

then i tried zerospu2 and a newer version of spu2, disabling the effects there seemed to work, however, when i tried to enable them again, i would still not hear effects, this lead me to believe that restoring a snapshot is not a good idea to test things, even when you restart the emu

so, i went with the original spu and disabled timestreching, let the game boot, and restored a save point from the ingame menu - the screeching was gone, even after 2 hours, not a single issue (btw i did not have any async audio so far)

Yeah bugs usually get 'recorded' in save states so when you load them even if you changed your settings, they still pop out. So another confirmation it's timestreching causing this, interesting. Could you also see if it's gone with Async mode too?
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)