Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[FIXED] Pnach Issue with Final Fantasy 12 (U)
Thumbs Down 
Hi there,

Having an issue with a cheat patch for my Final Fantasy 12.

Long story short (game details below) the cheat sort of worked but didn't work as intended, and so I removed it, but it is still in effect. I've actually included another Infinite MP cheat straight from a pnach here, but it didn't work or the old cheat overrode it. (I'm using the (U) version, this lastest cheat I added was for (E), I don't know if it's compatable or not). I've tried full reboots of PCSX2 and toggling enable/disable cheats but the darn thing won't go away. I fi Disable cheats, save state, completely close PCXS2, reload and load state, then move to another area about half of the cheats disable themselves, except the one cheat in question and a few others. If it matters, all of the cheats have been in one single .pnach file.

If anyone has any ideas let me know. I'm still combing as well to see if this has already been posted and I missed it. If I have please just link me to the original thread.

Game details (if this part matters to anyone who might know a direct fix)
The cheat was for Infinite MP for all characters.

I converted from an Action Reload MAX using Omniconvert and used the following format:

The cheat worked, except it only filled (and gave infinite to) only the first MP charge, as all of my party have all three charges. Now my characters gain MP from moving, dealing damage, taking damage and executing enemies, and the MP counter does climb after any of the battle MP gains, then immediatly drops back down to the same level it was before as if I casted a spell or something. Using a save crystal, the tecknik Charge or Ethers have the same effect.

Sponsored links

You're making sure not to load savestates that had the save right? When you disabled the cheat, you then restarted PCSX2 and loaded from a memory card save instead of a save state?
[Image: 2748844.png]
That's the problem, my drive saves come up as corrupt now so my only available save is from a save state taken when the cheat was active.

And now I can load hard saves again from the save crystals but only ones made after I added the cheats. Now I can make new saves and load them fine but can't load the two I have from before.


Alright, I'm not sure how this worked now of all times but I fixed it. Thanks Koji the save was definitely the issue.

At some point, after disabling cheats, then doing a hard save, loading the hard save, then reactivating the cheats I still have fixed it. Sorry to bother you guys with this. Close thread if needed.

If anyone has this error, try disabling your cheats and then using the save crystal (NOT a save state) to save, then reload with cheats DISABLED, then activate them once the game is running. It worked for me. Or just don't be stupid (like me) and keep either two seperate saves or always disable cheats before saving.
(04-06-2013, 04:38 AM)Wintersoul Wrote: Alright, I'm not sure how this worked now of all times but I fixed it. Thanks Koji the save was definitely the issue.

No worries, happens to the best of us (myself included). Since save states are captures of the entire memory, it includes any modifications you've done, even if you've disabled them.
[Image: 2748844.png]
I had this problem with Final Fantasy 12 aswell, I knew for 100% that the pnach was 100% correct and it still crashed FF12 or the emulator.

Users browsing this thread: 1 Guest(s)