Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS Drops with CPU Max Frequency (0.9.8)
#1
SPECS:
Intel core i5 430M w/ turbo boost (2.5Ghz)
4GB DDR3 RAM
ATI Radeon 5650 (1GB)
Windows 7 (64 bit)

Hey Guys,
I have been having random framerate losses with PCSX2 0.9.8 and I noticed something strange when watching with my Resource Monitor (Launched from the Task Manager Performance Tab). When the games are emulating fine (60 framerate) my CPU reads at 100-110% of max frequency (as it does with ALL games I've tried otherwise). Then, suddenly the CPU max frequency drops to 50% and I start experiencing framerates of around 30. This continues on for a little while before the framerate rises back to 60 (Along with the max CPU frequency to 100-110%). This makes the frequency bar on the resource manager look like a box sign wave. I've checked EVERY game I own, even tried turning up settings on graphics heavy games to lower my performance and I can't duplicate the issue. The same problem happens on native resoloution or 1600x900 (My laptop resoloution). Does anyone know whats causing this? Does anyone have a fix? I think this might have something to do with i5 hyperthreading or turboboost but I'm not sure.
Reply

Sponsored links

#2
Most likely it's overheating and throttle to cool down a bit. You can check your cpu temps with core temp or similar program to confirm that. It doesn't happen with normal pc games as they usually require less cpu power than pcsx2.
Reply
#3
-what game???
-btw it's but i5 doesn't have an HT only turbo boost luckly you got an i5 rather than i7 lappy since HT(laptop) hates pcsx2 more likely due to it's fast raising temperatures can cause a speed-breakdown.
-you maybe set gsdx reso at 1600x900 set back to default at 1024x1024
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#4
your cpu is hitting the OHP value and down throttling to prevent damage.
Reply
#5
I just grabbed a heat monitor, that's definitely whats going on. Thanks guys, I would have obsessed over that for days. I'm gonna look into cooling options now, but I'm not too sure how much that will help really. Anyone have any suggestions?
Reply
#6
you could always limit the MAX clock rate in the windows power settings.
Reply
#7
How would I do that? What max clock rate would you recommend to keep my heat down while maintaining a decent framerate?
Reply
#8
(08-08-2011, 04:17 AM)tallbender Wrote: -what game???
-btw it's but i5 doesn't have an HT only turbo boost luckly you got an i5 rather than i7 lappy since HT(laptop) hates pcsx2 more likely due to it's fast raising temperatures can cause a speed-breakdown.
-you maybe set gsdx reso at 1600x900 set back to default at 1024x1024

The only Arrandales without hyperthreading are the Pentium and Celeron variants. All i3/i5/i7 Arrandales are two core, four thread.

http://ark.intel.com/products/43537
Reply
#9
Problem solved, got some furniture coasters to stick under my laptop for extra airspace and I dropped my CPU output by 10%, still putting out near 60 framerate, no more slow downs. Thanks for all the help.
Reply




Users browsing this thread: 1 Guest(s)