Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS Jumps up Sometimes
#1
I'm currently playing Persona 3 on PCSX2 1.2.1.
And the thing is, its too fast.

I mean the fps goes over 60 sometimes, during loading screens and during fights etc it goes to 60-65 fps.
I've not tried any other games yet.

Framelimiting is NOT disabled.
I even have the entire Speedhacks disabled, see image below.
   

Im playing on HW Mode DX11 @ 2xNative. All default in GSDX.

Is there a way to make it stay exactly at 60?!

Specs:
•Intel Core i7 4702MQ @2.2 GHz, Turbo Boost Upto 3.2 GHz with (6MB Cache)
•8 GB DDR3
•Windows® 8.1 64-bit
•NVIDIA N14P-GV2 (gt740m - 2 GB )
Reply

Sponsored links

#2
It's normal for it to fluctuate like 58-62.

Turbo isn't on, right? (Tab key)

Enabling Vsync should stop it going over 60, if it's not from turbo. Go config->emulation settings-> gs window and check the last two boxes.

And you should enable the default recommended speedhacks. They are default for a reason.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
(06-13-2014, 06:28 AM)Blyss Sarania Wrote: It's normal for it to fluctuate like 58-62.

Turbo isn't on, right? (Tab key)

Enabling Vsync should stop it going over 60, if it's not from turbo. Go config->emulation settings-> gs window and check the last two boxes.

And you should enable the default recommended speedhacks. They are default for a reason.

No Turbos not ON.

K but could you explain what Vsync does?
Reply
#4
Vsync aka wait for vertical sync, makes sure the game does not draw frames during refreshes of your screen. When frames ARE drawn during that refresh, you get screen tearing. So vsync is a good thing anyway. But as a side effect, it will lock your frame rate to your screen refresh rate, or a number divisible by it's divisors.

Long story short, it will lock your game to 60 FPS.

The SECOND box make it adaptive vsync. Without the second box, if your machine couldn't keep the game at 60FPS and was instead say at 55 FPS, vsync would lock it to 30FPS, which is highly not desirable. So the second box turns off vsync if you fall below 60 FPS.

Together they cap your FPS at 60. This is not their main purpose, but it will work.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#5
K Got it. Thank you Blyss Sarania.
Reply
#6
Just to add that F4 toggles the frame limiter and could be cause of similar issue. As rule of thumb, the tittle window tells the mode the emulator is currently on, make sure "limiter" is normal instead turbo or none, which them tell you if the turbo is active or the frame limiter is disabled.

They are toggled by the TAB key and F4 key respectively as already stated. Yet, since they can be useful in special situations, follows the information that Shift + TAB does the inverse, halving the FPS, what may be useful mainly in certain minigames inside the actual game.
Imagination is where we are truly real
Reply
#7
Thank you for the Info, but like i've said, frame limiter is enabled and turbo boost is off.
I even had the entire Speed Hacks Disabled, Using Nvidia DX11 HW Mode and @ 2-3x Native Res and still FPS jumps to 63-65 every once in a while.
But the rest of the time FPS is fixed at 60.
I've only played Persona 3 so far in this system, since the game play is turn based, the speed ups doesn't matter that much.
I'm on my Balanced Power Plan when i play and I haven't tried playing anything else.

But i'm worried if this still keeps up, it might be hard to play Real Time Hack and Slash RPG's and Fighting etc.

Also i tried what you said Blyss Sarania, sadly this doesnt go away even with both the Vsync check boxes enabled.
Reply




Users browsing this thread: 1 Guest(s)