Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS capped at refresh rate?
#1
Hello, PCSX2 community.

I have a slight inconvenience. My PCSX2 seems to be capped at 75 FPS on desktop. 75 Hz is my refresh rate, so, I believe that's the reason. When I open full screen applications, I hear the emulator going faster (going beyond 75 FPS), creating further evidence to it being a refresh rate issue.

In my opinion, it sounds like a driver thing (I have a nVidia Geforce 770 GTX). I tried using application specific and also global settings on the drivers to see if something would change, but no. So, right now, I'm at loss and this would really be useful in some cases. (Playing Blitzball on FFX, and more FPS would make this a bit faster. ;P ).
Reply

Sponsored links

#2
Make sure that wait for vertical sync on refresh is NOT enabled in Config->emulation settings->gs window tab
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
(06-07-2014, 12:29 AM)Blyss Sarania Wrote: Make sure that wait for vertical sync on refresh is NOT enabled in Config->emulation settings->gs window tab

I checked, and it was already unchecked.
Reply
#4
Tried turbo-mode? Can be toggled by tab.
Reply
#5
(06-07-2014, 10:37 AM)willkuer Wrote: Tried turbo-mode? Can be toggled by tab.

I am using Turbo mode as I type this, and I only get 75 FPS. I also tried "None" limiter mode, same thing.
Reply
#6
Turn off turbo
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#7
(06-07-2014, 04:41 PM)Nobbs66 Wrote: Turn off turbo

I tried in normal, turbo and none modes, mutually excluded.
Reply
#8
Okay, PCSX2 community, I found the problem.

As I said earlier, I suspected it being the driver that pinned down to have Vsync on desktop. It was that.

Before, I had tried to turn off Vsync on Global Settings and see if it would stop capping the FPS. But, I simply applied and checked for results, nothing changed.

What I did different just now was restarting the computer after applying the settings. I first did with Global, worked, and then application specific, also worked.

Yes, I know, I should have done that before, but I was quite confident that simply applying the settings would instantly be reflected, but apparently not. Well, the issue is solved and that's the solution. Sorry for taking your time.
Reply
#9
You could create a specific profile for pcsx2.exe with NVIDIA Control panel
I5 - 2320 @ 3,0 Ghz - 8 GbyteDDR2 1333 Mhz - Geforce 8800 GTS 512 Mbyte - Win 7x64 - Samsung 32" TV HD-Ready
Uomo saggio il cielo aiuta.
Reply
#10
(06-07-2014, 08:33 PM)spike1977 Wrote: You could create a specific profile for pcsx2.exe with NVIDIA Control panel

That's what I ended up doing. As I said, I first tried with Global, worked and then with specific, worked as well.

Thanks for all the help, anyway. Tongue
Reply




Users browsing this thread: 1 Guest(s)