Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS dropped
#1
I wont bother to post my laptop specs in here since the emulator runs great on my laptop (fullspeed), though the problem is after a while, the fps dropped suddenly as if it doesnt have enough memory etc idk. The fps wont improve until i reset the emulator, its kinda annoying.

I don't know the best way to explain it, but this what happened when i tried to emulate Bleach: Blade Battlers 2nd,
-The game runs at full speed when starting the game
-Play 2-players match with my brother, still in full speed.
-After a while, like 2-3 match the fps starts to dropped. The more characters, skills ingame( especially that bankai) we used the earlier the fps dropped.
-The fps wont return to normal, until I reset the emulator.

note: I also tried to leave the game (like afk) in the middle of the match, even after hours the game still runs at full speed. If I tried to play the game, after some match the fps dropped as usual.

Also it happens to all of my games, Tales of abyss, persona etc.

idk, but it seems like memory deficit or something lol... I tried tweaks all the configuration already but no luck. Also tried on my desktop and same story...(though the start fps is kinda slow and the fps drop after awhile are more sooner, my desktop is inferior lol)

So I just want to ask is there anything i can do with this problem without reseting the emulator? like in option, clear the memory or something ...

Also,I tried to use the savestate, reset the emulator, then loadstate, the fps still slow, kinda wierd.
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
*. Your hardware specs - CPU, Graphics Card, Memory, Operating System.
*. The version of PCSX2 you are using.
*. Any non default settings you are using.
*. What games you are trying to play and if you are playing them from ISO or DVD.
Thank You.

I saved the time of devs by write this lol Tongue2
Reply
#3
Common thing to happen with laptops... it could be a few things, but most likely your laptop is either going into power save mode, or your CPU is getting too hot and your system is throttling down CPU speed to prevent overheating.


You can try setting your power mode to performance (just type "power" in the task bar and the power management settings should be the top thing on the list), or you can try looking at your CPU temps while you play and see if the slow downs coincide with temperature spikes.
Reply
#4
(04-03-2013, 08:01 AM)Preet Wrote: In order to help you further with your problem, please make sure the following are all provided.
*. Your hardware specs - CPU, Graphics Card, Memory, Operating System.
*. The version of PCSX2 you are using.
*. Any non default settings you are using.
*. What games you are trying to play and if you are playing them from ISO or DVD.
Thank You.

I saved the time of devs by write this lol Tongue2
Huh I was pretty sure its not my laptop problem since its happened to my desktop and I even tried on my bro's laptop too, oh well, I think I'll just stick to the rules lol.

Intel Core i7 2630. 2 GHz 6 MB L3 Cache.
NVIDIA Ge Force GT 540M Optimus
8GB DDR3
Windows 7 Home Premium 64
Its not the best specs but it runs the emu at fullspeed.

I tried all the pcsx2 version, even the latest from svn.
The settings is kinda random since I tried changed everything and same things happened.
Play from ISO, tried using DVD also same story.
Thanks for replying really appreciate it xD

(04-03-2013, 08:24 AM)Koji Wrote: Common thing to happen with laptops... it could be a few things, but most likely your laptop is either going into power save mode, or your CPU is getting too hot and your system is throttling down CPU speed to prevent overheating.


You can try setting your power mode to performance (just type "power" in the task bar and the power management settings should be the top thing on the list), or you can try looking at your CPU temps while you play and see if the slow downs coincide with temperature spikes.
It doesnt go to power save mode ,it was set to high performance all the time, and if it caused by overheating then why reseting the emu returned the fps back to normal?
Even after hours not using the emu, and shutting down my laptop, if I load the savestate(the savestate where the fps already dropped) the fps continues to drop around 20-25fps. Unless I reset the emu and not using that savestate, the emu runs at fullspeed...
Anyway I'll try monitor the cpu temp later, thx for replying tho Laugh
Reply
#5
(04-04-2013, 04:16 AM)unknownhex Wrote: Huh I was pretty sure its not my laptop problem since its happened to my desktop and I even tried on my bro's laptop too, oh well, I think I'll just stick to the rules lol.

Intel Core i7 2630. 2 GHz 6 MB L3 Cache.
NVIDIA Ge Force GT 540M Optimus
8GB DDR3
Windows 7 Home Premium 64
Its not the best specs but it runs the emu at fullspeed.

I tried all the pcsx2 version, even the latest from svn.
The settings is kinda random since I tried changed everything and same things happened.
Play from ISO, tried using DVD also same story.
Thanks for replying really appreciate it xD

It doesnt go to power save mode ,it was set to high performance all the time, and if it caused by overheating then why reseting the emu returned the fps back to normal?
Even after hours not using the emu, and shutting down my laptop, if I load the savestate(the savestate where the fps already dropped) the fps continues to drop around 20-25fps. Unless I reset the emu and not using that savestate, the emu runs at fullspeed...
Anyway I'll try monitor the cpu temp later, thx for replying tho Laugh

The previous posts pointed to the most probable causes already. Sometimes setting the power plan to performance may be override by the system to prevent heat throttling.

Still, there is another possibility the particular game is memory leaking and this is being saved in sstate. Note that's only a wild guess. If so there is not much to be done ATM at the user's side other than doing what you are doing already: resetting the emulator so the leak is cleared.

@devs
You may have a real bug to look upon with that game.

Edit: Sorry I can't test and provide detailed observation since I don't have the game.
Imagination is where we are truly real
Reply




Users browsing this thread: 1 Guest(s)