Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS is low on a few games
#1
Alright, so on half of the games that I currently have transferred to my PC have their FPS lowered some part after the intro. Currently those games are: Castlevania - Lament of Innocence, Dark Cloud 2, Okami, and Shadow of the Colossus. I've given up on SotC seeing as it says at 7-10 fps no matter what I do; however, I want to try to get those others to work.

PCSX2 version: 0.9.8(r4600)
Anyways, my specs are:
OS: Windows 7 Home Premium 64-bit
Motherboard: Pegatron Corporation 2AC2
Processor: Intel® Core™ i5-2400 CPU @3.10 GHz (4 cores)
Graphic Card: Intel® HD Graphics Family
Ram: 8.00 GB DDR3

Settings I have that aren't default:
Emulation Settings:
GS Window- custom Window size:1600x900
Speed-hacks- EE Cyclerate and VU Cycle Stealing both at 2

Plugin:
GS- GSdx 4600(MSVC 15.00, SSE41) 0.01.16[gsdx-sse4-r-4600]
RendererLaughirect3D10(Hardware)
2x Native

I believe that's about it for the settings.

Now then, more about what happens in the games.

For Dark Cloud 2, the beginning scene is about 30 fps instead of 60.

For Okami, it starts at 60, and throughout most of the introduction story it stays there, however when the story stops it dips into the 15fps range.

For Castlevania - Lament of Innocence, it starts at 60 for the story, goes down to 40 when the castle is shown(at the end of the story), then goes down to 20-30 when the Castlevania logo shows, then up to 50 for the new game, goes down to 23-25 when i start a new game, hits right back up to the 60 fps when the cutscene starts, and finally where I left off at the start of the actual game with 34 -45 fps and lags.
Reply

Sponsored links

#2
http://forums.pcsx2.net/Thread-Quick-Sta...ide-v0-9-8
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#3
Sigh.
The intel hd onboard gpu is the culprit for your slowdowns.You can't get comfortable playable speeds with that.If you can get a gpu upgrade.It'll help u a lot Smile
Intel core i5 3210m @3.1ghz
Nvidia Geforce GT650m 2Gb DDR5 (Core:975mhz/Memory:1000mhz)Cool
8Gb DDR3 1600hmz Ram
1Tb Hdd
1600x900 Hd resolutionBiggrin
Windows 8.1 64bit
Reply
#4
Due to the weak video card (that's not indented for gaming), most 3d games will run slow, you could possibly get better performance by changing over to software mode (F9)
Intel Core I7 [email protected](TB, HT), 6GB [email protected], Geforce 970 G1
Reply
#5
(06-26-2012, 07:48 AM)PostalDude Wrote: Sigh.
The intel hd onboard gpu is the culprit for your slowdowns.You can't get comfortable playable speeds with that.If you can get a gpu upgrade.It'll help u a lot Smile
Yeah, guess i would have to do that. Pretty dumb that they would put that graphics card on a computer that cost around $800.

(06-26-2012, 07:50 AM)hyakki Wrote: Due to the weak video card (that's not indented for gaming), most 3d games will run slow, you could possibly get better performance by changing over to software mode (F9)

So, would I just use F9, or just change my plugin from Direct3D10(hardware) to Direct3d10(software)?

Also, I noticed that in the software Mode Settings, it has Rendering threads, since my processor is quad core. Would changing the setting to 3 make any difference?

Anyways, with that it fixed my problems. Thank you.
Reply
#6
yeah you can fool around with render threads usually 2 or 3 will give the best performance with pcsx2, you should keep at least one separate thread open for the main pcsx2 process.
Intel Core I7 [email protected](TB, HT), 6GB [email protected], Geforce 970 G1
Reply




Users browsing this thread: 1 Guest(s)