FPS randomly speed up
Hello I was in the middle of playing Final Fantasy X and decided to take a break and made a save state in the middle of a boss fight so I wouldn't lose progress and have to start over(because i got screwed by a cash after boss and had to restart).When I came back to continue my FPS increased a lot.May I have help please.

Sponsored links

tried pressing F4 ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
nope just double checked and doing it too much made it crash
if it says "Limiter: Turbo" in the Titlebar press Tab to change it back to normal
(04-13-2012, 02:42 AM)hyakki Wrote: if it says "Limiter: Turbo" in the Titlebar press Tab to change it back to normal

is the title bar the one on the bottem when you first open the emulator that tells you what each F# does?

It's at the top of the window the game is displayed in.
o well i didint see it say that if im looking in right place what else could it be at.
No where else.

Make sure you're using one of the newer official PCSX2 programs.


If the game is running beyond natural full speed,
then either the limiter is disabled (toggle with F4),
the PCSX2 Turbo Mode is enabled (toggle with Tab),
or you literally changed the FPS setting in the .ini file.

If somehow you are having an error beyond that with your PCSX2 app,
maybe you should just re-download, and install PCSX2.

I recommend the binary package I linked, and putting it in a custom folder you make (i.e. "C:\PCSX2\").
Do not put PCSX2 in "Program Files", "My Documents", the "Desktop", or any other folders Windows makes itself.
do i need download all of them?also will my older version save states and game data from memcard work on this newer one i have 0.9.4?
I changed the link.
It will direct you straight to the specific download for the official PCSX2 0.9.8 binary package.

You are out of luck with your savestates, but I think the memory cards should be workable.

Users browsing this thread: 1 Guest(s)