Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Failed to read/write NVM/MEC file.(thread:EE Core)
#1
Tried searching for this and came up empty, but when selecting an iso, I get this error:

Code:
PCSX2 1.6.0-20200505220805
Savestate version: 0x9a0e0000

Host Machine Init:
    Operating System =  Linux 5.4.0-65-generic x86_64
    Physical RAM     =  15885 MB
    CPU name         =  Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
    Vendor/Model     =  GenuineIntel (stepping 03)
    CPU speed        =  2.589 ghz (8 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 7ffafbbf
    x86EFlags        =  2c100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Installing POSIX SIGSEGV handler...
Reserving memory for recompilers...

Loading plugins from /app/lib32/pcsx2...
    Bound   GS: libGSdx-AVX2.so [GSdx (GCC 9.2.0 AVX2/AVX2) 1.2.0]
    Bound  PAD: libonepad.so [OnePAD 20200505220805 2.0.0]
    Bound SPU2: libspu2x-2.0.0.so [SPU2-X 2.0.0]
    Bound CDVD: libCDVDnull.so [CDVDnull Driver 20200505220805 0.6.0]
    Bound  USB: libUSBnull-0.7.0.so [USBnull Driver 20200505220805 0.7.0]
    Bound   FW: libFWnull-0.7.0.so [FWnull Driver 20200505220805 0.7.0]
    Bound DEV9: libdev9null-0.5.0.so [DEV9null Driver 20200505220805 0.5.0]
Plugins loaded successfully.

(GameDB) 9858 games on record (loaded in 182ms)
HLE Notice: ELF does not have a path.

Initializing plugins...
    Init GS
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Patches: No CRC found, using 00000000 instead.
Opening plugins...
    Opening GS
Failed to init the freetype face
    Opening PAD
    Opening SPU2
Request SDL audio driver: pulseaudio
OpenGL information. GPU: Mesa DRI Intel(R) HD Graphics 530 (SKL GT2). Vendor: Intel Open Source Technology Center. Driver: (Core Profile) Mesa 20.1.3
INFO: GL_ARB_sparse_texture is NOT SUPPORTED
INFO: GL_ARB_sparse_texture2 is NOT SUPPORTED
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_compute_shader is available
INFO: GL_ARB_shader_storage_buffer_object is available
INFO: GL_ARB_texture_view is available
INFO: GL_ARB_vertex_attrib_binding is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_multi_bind is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available
INFO: GL_ARB_get_texture_sub_image is available

Current Renderer: OpenGL (Hardware renderer)
No extenstion supported to get available memory. Use default value !
Available VRAM/RAM:3840MB for textures
GSdx Lookup CRC:0
GSdx Lookup CRC:0
onepad: controller (Sony Computer Entertainment Wireless Controller) detected with rumble support, GUID:030000004c050000c405000011810000
Opened SDL audio driver: pulseaudio
    Opening CDVD
isoFile open ok: /home/kris/Games/PS2/Tom Clancy's Splinter Cell (USA).iso
    Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1384464 sectors)
    Opening USB
    Opening FW
    Opening DEV9
McdSlot 0 [File]: /home/kris/.var/app/net.pcsx2.PCSX2/config/PCSX2/memcards/Mcd001.ps2
McdSlot 1 [File]: /home/kris/.var/app/net.pcsx2.PCSX2/config/PCSX2/memcards/Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v01.60(07/02/2002)  Console
    BIOS r module not found, skipping...
    BIOS r module not found, skipping...
    BIOS e module not found, skipping...
# Initialize memory (rev:3.63, ctm:196Mhz, cpuclk:147Mhz detected)
NVM File Not Found, creating substitute...
[wx] can't open file '/home/kris/Games/PS2/ps2_bios/scph39001.nvm' (error 30: Read-only file system)
Closing plugins...
    Closing DEV9
    Closing FW
    Closing USB
    Closing CDVD
    Closing SPU2
    Closing PAD
    Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
(p) Failed to read/write NVM/MEC file.(thread:EE Core)


I've tried changing the permissions of both the file, and the folder, but no luck. Any help is appreciated.
Reply

Sponsored links

#2
that may be a bit dirty, but what if you
chmod -R 777 /home/kris/Games/PS2/ps2_bios && rm /home/kris/Games/PS2/ps2_bios/scph39001.nvm

and then run pcsx2 again ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(02-23-2021, 12:57 AM)jesalvein Wrote: that may be a bit dirty, but what if you
chmod -R 777 /home/kris/Games/PS2/ps2_bios && rm /home/kris/Games/PS2/ps2_bios/scph39001.nvm

and then run pcsx2 again ?

I'll give this a go when I get off work. Thanks for the reply. I'll post results.
Reply
#4
No luck. Same error.
Reply
#5
that "read only" thing is weird.
if not a permission problem, you may have a some process that locks this file.
if you do
ps -ef|grep pcsx2
while not running pcsx2 and get results, maybe you'll have to kill -15 it, or simply reboot your machine
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
do you know how to fix this problem for computer?
Reply




Users browsing this thread: 3 Guest(s)