Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fatal Frame/Project Zero/Forbidden Siren: Controlls not Working
#1
Hey guys, this is my first post, so I hope I don't break any of the rules. I am searching for days now, for a solution to this problem. It's about Fatal Frame (or Project Zero, as Europe knows it) AND Siren (from the Forbidden Siren Series). As you can see, I like my japanese horror.  Biggrin

Problem is, neither one of the games recognizes any form of controlls. I first tried Project Zero, because I am from europe, but even though lilpad shows the game pad, none of the controlls work ingame. My Gamepad is a noname ps3 controller and normally I would assume the gamepad to be the problem but when I go to "Test Device" in lilypad all of the commands are shown in a correct manner, just ingame nothing happens. 

I then tried an US-Version, only difference was that now I wasn't stuck at the language screen, because fatal frame has none, I was stuck at "press any button to continue". Keyboard and mouse also don't work. 

So I thought the problem was the game, maybe just try another japanese horror extravaganza, and Siren is actually from the silent hill dudes. 
But it's the same. The game starts just fine, I just can't press any button. 
I saw someone in a forum fix it via code but it was an old post, so I couldn't find the file any more. 


I always loved emulation for making old games immortal. Fatal Frame and Siren are old and it's really hard to get physical copies for ps2, especially if you don't want to sell your house. 

You know, the troubleshooting limbo. The emptiness, you feel after days of trial and error without any progress. That's the place from where I'm writing this. 
"Everyday I stare up at the cracks 
 In the ceiling and all I can think 
 about is how unfair it all is.... "
 

Thank you in advance,
Even if you tell me now, the games are completely unplayable and I should give up, you would've helped me  Biggrin



Here's data in case it's useful.  Laugh
I am using PCSX2 1.60 on a HP Omen 15 Gaming Notebook with Windows 10
CPU is an Intel Core i5-83000H @ 2.30GHz
8 GB Ram
And an NVIDIA GeForce GTX 1050
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Sure, here goes:

Code:
PCSX2 1.6.0-20200506140834- compiled on May  6 2020
Savestate version: 0x9a0e0000

Host Machine Init:
Operating System =  Microsoft Windows 10 Home (build 18362), 64-bit
Physical RAM    =  8040 MB
CPU name        =  Intel(R) Core(TM) i5-8300H CPU @ 2.30GHz
Vendor/Model    =  GenuineIntel (stepping 0A)
CPU speed        =  2.303 ghz (8 logical threads)
x86PType        =  Standard OEM
x86Flags        =  bfebfbff 7ffafbbf
x86EFlags        =  2c100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins from D:\Games\PCSX2\plugins...
Bound  GS: GSdx32-AVX2.dll [GSdx 20200506140834 (MSVC 19.25 AVX2/AVX2) 1.2.0]
Bound  PAD: LilyPad.dll [LilyPad (20200506140834) 0.12.1]
Bound SPU2: Spu2-X.dll [SPU2-X 20200506140834 2.0.0]
Bound CDVD: cdvdGigaherz.dll [cdvdGigaherz 20200506140834 0.11.0]
Bound  USB: USBnull.dll [USBnull Driver 20200506140834 0.7.0]
(GameDB) 9858 games on record (loaded in 159ms)
Bound  FW: FWnull.dll [FWnull Driver 20200506140834 0.7.0]
Bound DEV9: DEV9null.dll [DEV9null Driver 20200506140834 0.5.0]
Plugins loaded successfully.

HotSwapping to new ISO src image!
HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Patches: No CRC found, using 00000000 instead.
Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: D:\Games\PS2 Isos\Project Zero (Europe) (En,Fr,De,Es,It).iso
Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1831104 sectors)
Opening USB
Opening FW
Opening DEV9
3.x GL context successfully created
OpenGL information. GPU: GeForce GTX 1050/PCIe/SSE2. Vendor: NVIDIA Corporation. Driver: NVIDIA 451.67
INFO: GL_ARB_sparse_texture is NOT SUPPORTED
INFO: GL_ARB_sparse_texture2 is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_compute_shader is available
INFO: GL_ARB_shader_storage_buffer_object is available
INFO: GL_ARB_texture_view is available
INFO: GL_ARB_vertex_attrib_binding is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_multi_bind is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available
INFO: GL_ARB_get_texture_sub_image is available

Current Renderer: OpenGL (Hardware renderer)
Available VRAM/RAM:3840MB for textures
GSdx Lookup CRC:0
McdSlot 0 [File]: C:\Users\Satan\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\Satan\Documents\PCSX2\memcards\Mcd002.ps2
GSdx Lookup CRC:0
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: Europe  v01.60(04/10/2001)  Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
# Initialize memory (rev:3.63, ctm:196Mhz, cpuclk:147Mhz detected)

PlayStation 2 ======== Hard reset boot
ROMGEN=2001-1004, IOP info (CPUID=1f, CACH_CONFIG=0, 2MB, IOP mode)
<20011004-175839,ROMconf,PS20160EC20011004.bin:11520>
# Total accessable memory size: 32 MB (B:2:8:0) (363:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Jul  4 2001 16:03:45
  CPUID=2e20, BoardID=0, ROMGEN=2001-1004, 32M

Patches: No CRC found, using 00000000 instead.
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_508.21;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
LilyPad: Warning! No controls are bound to a currently attached device!
Please attach a controller that has been setup for use with LilyPad or go to the Plugin settings and setup new controls.
found 9735 symbols
ELF (cdrom0:\SLES_508.21;1) Game CRC = 0x22E91837, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_508.21;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SLES_508.21;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SLES_508.21;1
0 00100000 0025e4cc ......................................
Loaded, cdrom0:¥SLES_508.21;1
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Elf entry point @ 0x00100008 about to get recompiled. Load patches first.
comment: - At least when using GSdx in D3D11 HardWare mode, and due to missing
comment: -  rendering-fixes, black stripes can show up on ghosts,
comment: -  spirits and photos, when Upscaling and\or using WideScreen-patching.
comment: - This can be fixed by having "Enable HW Hacks" set
comment: -  in the GSdx configuration dialog, and having "Align Sprite" set
comment: -  and "Sprite" set to Half in "Advanced Settings and Hacks".
Get Reboot Request From EE
ROM directory not found
GSdx Lookup CRC:22E91837
GSdx Lookup CRC:22E91837

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver. 2.1
    Copyright 1999-2001 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadmodule: fname cdrom0:¥LIBSD.IRX;1 args 0 arg
loadmodule: id 25, ret 0
loadmodule: fname cdrom0:¥SDRDRV.IRX;1 args 0 arg
SDR driver version 2.0.0 (C)SCEI
Exit rsd_main
loadmodule: id 26, ret 0
loadmodule: fname cdrom0:¥SIO2MAN.IRX;1 args 0 arg
loadmodule: id 27, ret 0
loadmodule: fname cdrom0:¥PADMAN.IRX;1 args 0 arg
loadmodule: id 28, ret 0
loadmodule: fname cdrom0:¥MCMAN.IRX;1 args 0 arg
loadmodule: id 29, ret 0
loadmodule: fname cdrom0:¥MCSERV.IRX;1 args 0 arg
loadmodule: id 30, ret 0
loadmodule: fname cdrom0:¥IOPSYS.IRX;1 args 0 arg
loadmodule: id 31, ret 0
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps
padman: *** VBLANK OVERLAP ***
padman: *** VBLANK OVERLAP ***
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Delete 0 Shaders, 39 Programs, 28 Pipelines
Plugins closed successfully.
Reply
#4
Quote:LilyPad: Warning! No controls are bound to a currently attached device!
Please attach a controller that has been setup for use with LilyPad or go to the Plugin settings and setup new controls.
this is probably where your problem lies.

does this fake controller work on your real PS2 ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
(10-06-2020, 04:04 PM)jesalvein Wrote: this is probably where your problem lies.

does this fake controller work on your real PS2 ?

Wow, okay yeah this seems quite clear, tank you! Ohmy

I never tried it with the real PS2, because i have an official non-usb PS2 controller for that. I only use the fake one for PC, but it worked on sekiro. 
Back then I used x360ce to emulate a 360 controller with the fake one. I tried this with lilypad to no effect.

(I will try the fake controller on my PS2 and tell you, if it worked)



EDIT: Nevermind, problem is solved now. They key was the line from the log. Lilypad recognized the commands, but it didn't translate them to PS2. I had to map the buttons from Ps3 pad (or PC controller as lilypad calls it) to ps2 pad. Still, some confusion is left because I played Odin Sphere little while ago and didn't have this problem. 
Anyway, I can't thank you enough! Smile
Reply




Users browsing this thread: 1 Guest(s)