Final Fantasy 10 Crashes
Without getting into to much detail, I basically downloaded Final Fantasy 10's v.NTSC, and am trying to play it. I get through the first few cutscenes, and in total can play for about 6-8 minutes. Final I crash at the first few battles.
Some detail would be that when I first tried this game, I had PCSX2 v. Now I have v.1.0.0, and it made it a little bit further than did, but still crashed. Then I tried it again on 1.0.0, and it crashed, yet another time, a little bit further than it did last time on 1.0.0.
I'm thinking that the problem is a ready error, not an ISO error, because it's not crashing in the same spot. But honestly, I could be hitting an anvil with a plastic hammer right now, because I'm not entirely sure.
Any suggestions?

Also, how do I go about changing the plugin for ISO loading? I'm fairly new to PCSX2.

Sponsored links

Quote:I basically downloaded Final Fantasy 10's v.NTSC

Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)