Final Fantasy X-2 hang []
Hey, after playing FFX all the way through on PCSX2, I was talking to my friend about X-2, gave me the urge to boot that up again.

I know about the FMV problems, I just switch to software renderer for that, but at the beginning of the game, right after the first battle with hte Leblanc Syndicate (so I'm talking about 10 minutes into the game here), the screen hangs. The music keeps on playing, but the frame just sits there.

Specifically this frame.

I tried switching software/hardware renderers, disabling all speedhacks, turning on/off a load of fixes (specifically OPH Flag Hack and EE timing hack), I usually use GSDX, but I tried switching to ZeroGS, no difference, still hangs.

Using PCSX 0.9.7.

Windows 7
Intel Core i5 CPU 760 @ 2.80GHz
NVIDIA GeForce GTX 460 1GB

be my system specs.

Any help would be greatly appreciated =].

Sponsored links

Are you using the DVD or the ISO? Try to make an ISO off the DVD and use it to play, and turn off all speedhacks.
disk read failure.
I made an ISO. Same method that I used for FFX, which worked fine. The disk is in fine condition too. Can't be a disk read failure.
it can ALWAYS be a disk read failure.

try reading the image with cdvdolio
May or may not be disk read failure. Some games hang even though the iso or dvd or proper.

Possible Reasons:

1)Disk Read Failure - as said above but may or may not be
2)Too Load on CPU Tongue2
3)Final Fantasy SLES 51817 is only INGAME on 0.9.2 Smile

Check the 3'rd point
2. too much load is never a reason for hangs.
3. hes using 0.9.7 not 0.9.2.
[Image: ref-sig-anim.gif]

If it's a disk read error, what would you suggest? I tried using different plugins to read, with no avail.

Try ripping the ISO again maybe?
(04-10-2011, 05:37 PM)refraction Wrote: 2. too much load is never a reason for hangs.
3. hes using 0.9.7 not 0.9.2.

another outdated compatibility game Wink
...So... any consensus?

Hell, I'd be happy with a game save past that scene, but I'm not entirely sure how to add saves to the PCSX2 memcard, I used MyMC to inject a game save, but I don't know which format it takes. MAX doesn't seem to be recognised.

Users browsing this thread: 1 Guest(s)