Final Fantasy X Crash
So im playing final fantasy x and the game crashes every time druing the cutscene at the end of the Home level. It crashes at different times of the cutscene and nothing shows up on the console. It just says pcsx2 is not responding. Anyone know this issue. I've tried different graphics settings and that just makes the game crash faster and have worse graphics.


Sponsored links

trying from the disc, or Iso ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Try the latest beta, there's a known crash at home that should be fixed with it. If you're already using it please post your settings.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Yep, latest beta should fix this. I also had that crash in 0.9.6, but after installing r1888, had no further crashes all the way through to the end of the game.
[Image: yunacopy.jpg]
I'm using an ISO.

I'm already using the newest beta. My settings are:

Graphics: GSdx 890 (MSVC 15.00, SSE41) 0.1.14

-NLOOP Hack on
-Texture filtering on

CPU settings:

-EERec is on
-MTGS is on


-INTC Sync hack on
-IOP x2 cycle rate is on
-WaitCycles Sync Hack is on

I'm not using any patches and I'm running windows vista. I've tried turning off the speedhacks and changing my graphics settings but that just made it worse.
Graphics: GSdx 890 (MSVC 15.00, SSE41) 0.1.14 <-- yeah that doesnt looks like part of the beta... what beta did you say it was?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
My bad, the newest beta fixed it. I installed the newest beta but accidentally opened the same version. I didn't realize it created a new folder.

Thanks for the help.

Users browsing this thread: 1 Guest(s)