Final Fantasy X (International) Inexplicable lag during area transitions
I've been playing through the international version of Final Fantasy X on PCSX2 with few problems for several days. Just today, however, I've started to encounter massive slowdown and audio glitches when transitioning areas, and scenes that I previously had no trouble rendering now bring me down to 30 fps. Below are what conditions I can recall, and my emulation settings.

With the exception of the Mi'ihen Highroad, I was stable at 60 fps (or above when Turbo grinding) from the beginning of the game to the Spherimorph fight in Macalania Woods. After that, I did some backtracking for Jecht spheres and to recruit some Blitzball players, and the lag started to get really awful when I got back to Besaid. I've reloaded some prior saves and places where I had no lag yesterday (Thunder plains, etc) are now extremely slow, and there is even more lag and weird audio spikes during area transitions.

My settings (which have remained unchanged throughout the playthrough) are:

GSdx 5334: Direct3D10 (Hardware), usually 2x Native resolution
(now lags even on Native), no 8-bit textures, filtering, shade boost, or AA.
SPU2-X: Interpolation 2 - Cubic, Module: XAudio 2, Synchronizing Mode: Async

Bios: USA v01.60

EE Cyclerate 2
VU Cycle Stealing 1
INTC Spin Detection
Wait Loop Detection
mVU Flag Hack

FFX videos fix

I'm running Windows 7 Ultimate 64 bit on a 2009/2010 MacBook, so the video card is pretty bad (a 320M I think), but it was working fine until today, so I don't think it's a hardware issue. I haven't done anything else with the machine in the last couple days that I can pin this change on.

If anyone has any ideas (or might be able to help if I forgot a vital piece of info), please let me know.

Sponsored links

Consider inverting the settings there

VU cycle stealing at 2
EE cyclerate at 1 (maybe it is not even needed with the above).

The problems with the sound are most probably due to EE hack actually and that amount of it says the EE core is "running" at very low speed.

About the MTVU, it is not going to help and possibly making things worse unless the CPU is Intel and have 4 cores, anyway try with it deactivated also.
Imagination is where we are truly real
Have in mind also that Speedhacks sometimes work exactly the opposite way than what you may thought they would.
Let's take Tekken series, even the slightest touch in VU cycle stealing and EE cyclerates options will make the game really slower.
That's because the game is heavily based on accurate and specific timing of those two and will wait until the whole cycle gets completed to perform some actions, hence if you decrease the cycles this will take for it longer to perform an action.
So play a little bit with those to find the best balance.
Disable 8 bit textures. Fixed it for me
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)