Final Fantasy X PAL interlace during FMVs (figured out)
EDIT: I confirmed that this doesn't happen in the NTSC version of the game, which works flawlessly.

I'm playing FFX, the spanish PAL version of the game, and I get this interlaced like effect during FMV cutscenes. It's not that bothersome, but during cutscenes with a lot of movement, such as the very first one during the Blitball game, it becomes way too obvious and some times it even makes it hard to tell what's going on. I added a screenshot, jut for you to check.
I tried hitting F5 several to cycle though all of the interlace options, and none of them seemed to solve the problem, even the "off" setting (no interlace) didn't do a thing. I reverted to native resolution rather than 3X, didn't work.

Changing to software mode didn't do a thing either, so I'm kind of puzzled about this. It happens both in 1.0.0 (r5350) and r5418. I'm using DX10.

Could it be that it's a problem with the way the videos were encoded for the PAL version, and this doesn't happen to the NTSC one at all?

My stats, should hat matter (although I don't think so, as the game itself runs wondrously) are: Core2 quad @ 2,6 GHz, GeForce 8800 GTX, 4 GB RAM, windows Vista 32 bits.

On another, slightly unrelated note, in order to get to the intro cutscene fast, I activated turbo (deactivated it when I arrived to the stadium and was swarmed by the fans, so it had no effect on the FMV interlacing). The game got to an overall 90fps, the ingame animations became wonderfully smooth, and I noticed something.
There's certain stuttering with the motion captured animations in the PAL version. Nothing to do with the emu, as that happened even when playing the game on a real console as a consequence of the game going 50FPS, 20% slower than the original (it is specially noticeable when Tidus was posing his hand on Yuna's shoulder, it seemed as if he was shivering and shaking) , but this stuttering wasn't noticeable at all when the game was going faster, so I was wondering, is the stuttering noticeable in the NTSC version? If not, and should the FMVs interlacing not happen with the NTSC version of the game, maybe I should use that and call it a day?

Attached Files Thumbnail(s)

Sponsored links

The current version of PCSX2 have issue with FFX FMVs. I do not have Spanish version so I do not know, but the International version and US version have FMV problem, which did not occur on 0.9.8. Software mode fixes it however. Cannot blame GSDX plugin if Software mode does not fix your problem. Perhaps you should report in the Bug Reporting section.

Currently I have NTSC-U, PAL-E, and International (NTSC-J) versions. I do not notice anything odd in the opening scene (could be my eyes), but I'm sure there is no such interlacing effect like yours. Both NTSC-U and International version were run on PCSX2 1.0. For the PAL-E version, I ran it on PCSX2 0.9.6 long ago, and I'm a bit lazy to do it now as it takes ~15 mins to go to the first FMV.

You should try PCSX2 0.9.8 and see if the problem persists.

P.S: Another possibility is that it is "motion blur" effect PCSX2 team adds to enhance FMV experience. Laugh
Thanks for your reply!
Tried the 0.9.8 version. After about 5 minutes I got to the FMV and, yep, same problem. So I'm guessing it has something to do with the way the FMVs are encoded. Maybe the problem is there in the actual game already but it is not noticeable in a 50Hz CRT TV set.

I remember the guys at Square saying that they didn't implement a 60 Hz selector in the sequel (FFX-2) because there was not enough disk space to include the FMVs both in 50 and 60 Hz (although that didn't explain why didn't they implement any short of overscan either Angry ). If they have to encode the videos in two different formats for the NTSC and PAL versions, it might be a possible explanation. So, yeah. I'm going to try the NTSC version, better framerate for ingame animations, anyway.

If anyone can come up with a more plausible explanation, or better yet, a workaround, please do so.

Also, trying 0.9.8 made me appreciate the devs hard work even more. It is amazing how much the performance has improved. In v 1.0.0 onwards, I get over 100 fps with no speedhacks. The 0.9.8 struggled to get to 50 fps. Amazing.

EDIT: I was curious, so I tried Spain PAL FF XII and, although it's neither as hard not as noticeable, there's also some of this weird interlacing issue. It is not by far as annoying as it is in FFX, but it is there. I have tried some other PAL, 50 Hz games and haven't found this issue. Then again, each company has it's own way of encoding FMVs.
The videos are encoded with Interlacing, i guess you could keep hitting F5 (might be F6 i forget...) until you get a form of interlacing you like, but there's nothing PCSX2 can do, unless someone comes up with a magical replacement for GSDX's interlace handling
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
hit F5 (software mode) for FMVs, even my weak PC can handle them
(09-24-2012, 05:33 PM)refraction Wrote: The videos are encoded with Interlacing, i guess you could keep hitting F5 (might be F6 i forget...) until you get a form of interlacing you like, but there's nothing PCSX2 can do, unless someone comes up with a magical replacement for GSDX's interlace handling

It's F5. As I said, I tried all of the interlacing options to no avail. It seems as if the video is outputting that way regardless of what the emu or GSDX do.

Saiki Wrote:hit F5 (software mode) for FMVs, even my weak PC can handle them
Software mode (F9 key) did not solve the problem. I was going to get my hands on the NTSC international version to see if the problem persists.

Which version of the game are you using? PAL or NTSC? If it is NTSC, are the videos encoded with interlacing as well?
I have PAL and NTSC, but I haven't played since 0.9.9
I got my hands in the NTSC international version, and the problem didn't happen. FMVs displayed beautifully, and the game overall looks and plays awesome.

EDIT: I tried the same with Final Fantasy XII and it happened to be the same. The NTSC version displays FMVs with no interlace whatsoever.

My guess, it seems that the PAL videos are interlaced already and that's the way they work on real hardware. The interlacing isn't noticeable when playing in a standard PAL tv but when displaying it in a different screen it becomes more apparent. I don't know if this is the case with any other PAL, 50 Hz only, games, or just Square ones.

So, the "solution" to this problem when it comes to the emu would be either to:
A) change to the NTSC versions of the game,
B) a highly complicated and totally not worth the effort deinterlacing option for the videos of the PAL version alone, which, seeing it is easier to just go for the NTSC version, I think would be too much work to change something that is basically the way the game worked originally.

However, what really puzzles me is why would they interlace the FMVs to begin with.
I would understand, should it be to take advantage of the higher resolution of a PAL CRT TV set, but in the end, the PAL game had no overscan at all and was streched vertically, so it actually ran at the same resolution as the NTSC game did, but 20% slower!
Maybe they were planning on overscanning the game, interlaced the videos, then dropped the option but left the videos interlaced? Who knows...
As said above, I played the PAL-E version on 0.9.6 and there was no such interlaced effect. It is either because of the PAL-ES version, or because of PCSX2 1.0.
Hey guys, I have to tell you that there is definitely the same problem with the PAL-G (german) version - just to underline that the interlaced issue really exist. Now it's the second day I have checked all the possibilitys in pcsx2, finally extracted the videos per ffx2mov and checked the properties: 25fps, scantype is flagged as progressive and the picture material itself is - hooray - interlaced. It's just exactly like terminento said, but this idiocy isn't the only one. I had similar issues with the video material from Walt Disneys "On The Front Lines", but that material could be changed back to interlaced scantype with ReStream v090. Had cost me some days to figure that out. The alternative would have been watching the material with the vlc player and put its deinterlacing option manually on. But in this case (FFX) I have no idea how to get to the original video files, patch them, and go back. Well, maybe this information helps someone to do so - or just change the videofiles with the files from an ntsc version. Anyhow, the international ntsc version works brilliant so far. Thanks a lot for this hint :-)

To return the favor here's the configuration setup for the correct aspect ratio using the 1920x1080 screen resolution. In FFX the original aspect ratio should be something like 3:2 (shouldn't be there originally some black borders?) but in pcsx2 you only have the choice of 16:9, 4:3 and a complete stretch to your actual screen resolution. That's a complete fail because full hd monitors usually don't come with 3:2 support. Anyway, in the window configuration (configuration -> video -> window configuration) set up your window size to 1440x960, zoom should be at 84.00 and aspect ratio on "use full window". Start the game, doubleclick or press alt+enter to get into the fullscreen mode. Now stretch the picture with STRG+ALT+NUMPADPLUS until you reach the bottom/top, have fun. Or else you can use the widescreen cheat but if you ask me that thing also doesn't scale proper so you have to stretch it to the correct aspect ratio as well and if you wanna see the complete map on the upper left you'll loose some picture information at the top/bottom because you have to scale down this time (STRG+ALT+NUMPADMINUS). Don't forget, this setup only goes if your native screen resolution is 1920x1080 (but I guess that's the standard nowadays).

Users browsing this thread: 1 Guest(s)