Final Fantasy X Settings
I am running Final Fantasy X, i own both a playstation 2 and game (Playstation laser is too weak to read some disk due to use.

Everything runs perfect, but when FMV starts I get the last frame before the FMV sequence hanging over the FMV and constantly Flickering and the last 3rd of the screen is distorted.

My system is :

AMD FX 6300 Black Edition Six Core Processor 3.8Ghz
Corsair 2100mhz 16GB
256GB SSD OCZ - Games and Programs
1TB 7200 barracuda - Data
3GB 7970 Radeon HD

You should see the game when i take the framelimiter (F4) off made grinding stupidly quick.

Can someone just give me a breakdown of what settings they have when running this game and what plugins they use. Almost finished game and i think i only have the ending vid left.

I tried recording the game with a phone but it dont pick up the flickering so i get perfectish picture lol

Sponsored links

Go to config> Emulation Settings> Game Fixes

Click the box at the top to enable them. Now click on the one that says FFX video fix. See if this does anything. I never had a problem with videos playing in FFX but just try it out and see if that fixes it for you.
I5 3570k 3.4ghz| 4GB R9 290| 8GB DDR3
I have the same issue as the OP with FFX FMVs rapidly flickering between the last 3D image prior to the FMV starting and the actual FMV. This is with the FFX video fix automatically on, manually checked on, off, speedhacks on and off... among other settings I tried toggling.

The FFX video fix was designed to prevent the grey "garbage" overlay thing on the FMVs, at least according to the description in the configuration guide. This seems to be a different issue.

Intel Core i7 920 @ 2.79 GHz
AMD Radeon HD 5870
Catalyst 12.10
Windows 7 x64 SP1
Hmm it might only be a problem with the NTSC version of the game for some odd reason. I have the international version and this does not happen to me.
I5 3570k 3.4ghz| 4GB R9 290| 8GB DDR3
Try switching to software mode (F9) during FMV playback. If that fixes it, the manual gamefix to switch to software rendering for FMV playback, found in newer svn revisions, will come in handy here.
(08-18-2012, 02:34 PM)Livy Wrote: Game: Final Fantasy X
Version: NTSC-U (SLUS-20312) & NTSC-J (SLPS-25088)
GSDX: The one bundled with PCSX2 1.0.0

Bug description: Few FMVs in NTSC-U version of FFX and the majority of FMVs in the International version blink. Automatic game fixes is checked (this bug is not the gabarge FMV which the gamefix is for). I did a full test with the FMV when Tidus meets Wakka in the International version. All speedhacks and GSDX hardware hack are off, cheats disabled, native resolution, change between microVU and superVU but the problem still persists. The only way to fix it is using Software mode.

Workaround for user: Press F9 to switch to Software mode either before or after the FMV. Then press F9 again (immediately if you want to) to switch back to Hardware mode.

Users browsing this thread: 1 Guest(s)