Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final Fantasy X refuses to start
#1
So i just recently got into my old collection of ps2 games that has been in my mothers shed (which she finally went through) for about 5-10 years maybe longer and decided to rip them all to my computer via imgburn since my ps2 is out of commision *cries* damn rats :|

after i finished i decided i wanted to play final fantasy 10 again so i opened it in pcsx2 1.2.1 and surprise a black screen that sits there for hours doing nothing :|

i thought maybe it was fixed in one of the dev versions so i downloaded a newer version and sure enough it wasn't fixed

Can someone tell me what settings i should use to get my game to work.


here is my emulog

Code:
PCSX2 1.3.1-20150416222809 - compiled on Apr 16 2015
Savestate version: 0x9a0a0000

Host Machine Init:
    Operating System =  Microsoft  (build 9200), 64-bit
    Physical RAM     =  32202 MB
    CPU name         =  Intel(R) Core(TM) i7-4700HQ CPU @ 2.40GHz
    Vendor/Model     =  GenuineIntel (stepping 03)
    CPU speed        =  2.393 ghz (8 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 7ffafbbf
    x86EFlags        =  2c100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. FMA

Reserving memory for recompilers...

Loading plugins...
    Binding   GS: C:\Users\Kamijou\Documents\PCSX2\plugins\GSdx32-SSE4.dll
Windows 6.2.9200
    Binding  PAD: C:\Users\Kamijou\Documents\PCSX2\plugins\LilyPad.dll
    Binding SPU2: C:\Users\Kamijou\Documents\PCSX2\plugins\SPU2-X.dll
    Binding CDVD: C:\Users\Kamijou\Documents\PCSX2\plugins\cdvdGigaherz.dll
    Binding  USB: C:\Users\Kamijou\Documents\PCSX2\plugins\USB_VB.dll
    Binding   FW: C:\Users\Kamijou\Documents\PCSX2\plugins\FWnull.dll
    Binding DEV9: C:\Users\Kamijou\Documents\PCSX2\plugins\DEV9ghzdrk.dll
Plugins loaded successfully.

(GameDB) 9677 games on record (loaded in 176ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
    Init GS
Windows 6.2.9200
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
    Opening CDVD
isoFile open ok: C:\Users\Kamijou\Documents\PCSX2\games\Final Fantasy X ntsc-u slus-20312.iso
    Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2234448 sectors)
    Opening USB
    Opening FW
    Opening DEV9
Opening adapter '\Device\NPF_{1319F185-A244-456E-91D0-420EC0FF81BA}'...Device uses DLT 1: EN10MB
Ok.
McdSlot 0: C:\Users\Kamijou\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Kamijou\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v02.20(10/02/2006)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
BD Byteswapping enabled.
SMAP_R_EMAC3_TxMODE1_L 32bit write 380f0000
Adapter Detection Hack - Resetting RX/TX
* pcap io: Sending 1514 byte packet.
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_203.12;1
(SYSTEM.CNF) Software version = 0.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_203.12;1) Game CRC = 0xF0800C1E, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_203.12;1
(SYSTEM.CNF) Software version = 0.01
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_203.12;1
(SYSTEM.CNF) Software version = 0.01
(SYSTEM.CNF) Disc region type = NTSC
(GameDB) Enabled Gamefix: IpuWaitHack
Overall 0 Widescreen hacks loaded
EE/iR5900-32 Recompiler Reset

and here is my settings (see attachments below)


Attached Files Thumbnail(s)
       
ASUS ROG G750JM
Intel i7-4700HQ CPU @2.40GHz (Overclock 3.7GHz)
Intel® HD Graphics 4600
NVIDIA GeForce GTX 860M
32.0GB RAM
Reply

Sponsored links

#2
Default settings work fine for this game. Change your dev 9 plugin back to null and try.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
uncheck enable Manual Game fixes in the Gamefixes section.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#4
enable game fixes is unchecked

speed hacks was enabled so i disabled that >.>

i reset all settings and set dev9 to null

nothing changed

EDIT: wow that took a while

like 10 seconds of blank screen before it started

thx guys
ASUS ROG G750JM
Intel i7-4700HQ CPU @2.40GHz (Overclock 3.7GHz)
Intel® HD Graphics 4600
NVIDIA GeForce GTX 860M
32.0GB RAM
Reply
#5
@Blyss
is the following gamefix automatically enabled for FFX ?

Code:
(GameDB) Enabled Gamefix: IpuWaitHack

(04-17-2015, 11:17 AM)Kamijou Touma Wrote: wow that took a while

like 10 seconds of blank screen before it started

thx guys

what resolved the issue ? disabling speedhacks ? can you post the new emulog on which the game worked, Thanks. Smile
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#6
Well the (GameDB) in front at least supports this theory...
Reply
#7
(04-17-2015, 11:23 AM)willkuer Wrote: Well the (GameDB) in front at least supports this theory...

yeah, you're right. I was too dumb to notice it. Tongue2

to just confirm it, gave a look at the source at github and the IPU wait hack is enabled for the FFX game.
so, something on the speedhacks side must have caused the issue. Smile
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#8
disabling the dev9 plugin resolved it
it seems the dev9 plugin for fragment doesn't like ffx very much

Code:
PCSX2 1.3.1-20150416222809 - compiled on Apr 16 2015
Savestate version: 0x9a0a0000

Host Machine Init:
    Operating System =  Microsoft  (build 9200), 64-bit
    Physical RAM     =  32202 MB
    CPU name         =  Intel(R) Core(TM) i7-4700HQ CPU @ 2.40GHz
    Vendor/Model     =  GenuineIntel (stepping 03)
    CPU speed        =  2.392 ghz (8 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 7ffafbbf
    x86EFlags        =  2c100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. FMA

Reserving memory for recompilers...

Loading plugins...
    Binding   GS: C:\Users\Kamijou\Documents\PCSX2\plugins\GSdx32-SSE4.dll
Windows 6.2.9200
    Binding  PAD: C:\Users\Kamijou\Documents\PCSX2\plugins\LilyPad.dll
    Binding SPU2: C:\Users\Kamijou\Documents\PCSX2\plugins\SPU2-X.dll
    Binding CDVD: C:\Users\Kamijou\Documents\PCSX2\plugins\cdvdGigaherz.dll
    Binding  USB: C:\Users\Kamijou\Documents\PCSX2\plugins\USB_VB.dll
    Binding   FW: C:\Users\Kamijou\Documents\PCSX2\plugins\FWnull.dll
    Binding DEV9: C:\Users\Kamijou\Documents\PCSX2\plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9677 games on record (loaded in 173ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
    Init GS
Windows 6.2.9200
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
    Opening CDVD
isoFile open ok: C:\Users\Kamijou\Documents\PCSX2\games\Final Fantasy X ntsc-u slus-20312.iso
    Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2234448 sectors)
    Opening USB
    Opening FW
    Opening DEV9
McdSlot 0: C:\Users\Kamijou\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Kamijou\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v02.20(10/02/2006)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_203.12;1
(SYSTEM.CNF) Software version = 0.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_203.12;1) Game CRC = 0xF0800C1E, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_203.12;1
(SYSTEM.CNF) Software version = 0.01
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_203.12;1
(SYSTEM.CNF) Software version = 0.01
(SYSTEM.CNF) Disc region type = NTSC
(GameDB) Enabled Gamefix: IpuWaitHack
Overall 0 Widescreen hacks loaded
EE/iR5900-32 Recompiler Reset

i can assume the reason is because the game doesn't support network play >.> just an assumption though
ASUS ROG G750JM
Intel i7-4700HQ CPU @2.40GHz (Overclock 3.7GHz)
Intel® HD Graphics 4600
NVIDIA GeForce GTX 860M
32.0GB RAM
Reply
#9
yeah, that plugin breaks most of the games.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#10
on a side note this game has amazing graphics for a ps2 game and is surprisingly non intensive

thx for your help guys
ASUS ROG G750JM
Intel i7-4700HQ CPU @2.40GHz (Overclock 3.7GHz)
Intel® HD Graphics 4600
NVIDIA GeForce GTX 860M
32.0GB RAM
Reply




Users browsing this thread: 1 Guest(s)