Final Fantasy XII CGI Glitch (solved)
Hi All

Thanks to a few threads here I went out and bought a copy of FF12 and it works on my pc ! Amazing work by the devs , didnt know this kind of emulation was possible. I followed some posts here to set up the game and its running fine except for the scences that cut to CGI in the game they are a glitchy, Is there a fix for this ? Not really a game breaking problem at all but id like to know if its just me that gets that Smile Cool forum btw. My Ps2s drive broke but now I dont need to buy a new one !


Sponsored links

Glitchy doesn't really describe it. You also did not post which PCSX2 version you are using, which plugins or your system specs. With no info no one can actually help you...
[Image: newsig.jpg]
The CGI scences including the introduction dont run very well, the auido is jerky and the video flashes , its just the CGI scenes though.

Im using PCSX2 0.9.6
Inter Core duo E8400
4gb Ram
nvidia 8800 gt
windows 7

I followed this thread to set up PCSX2 ...
Speedhacks break this game, especially the x2 cycle rate hack. Disable it and it will probably run perfectly then
[Image: newsig.jpg]
tried turning that off but still the intro and cutscenes are not working very well, I take it the cutscenes work fine for you ?
Yep working fine. I think the PAL version has some extra problems, maybe you have that region.
I suggest trying the latest released beta revision 1888 with it, see if that makes any difference.
[Image: newsig.jpg]
try the latest beta r1888
thanks guys, yeah I have the PAL version, its not that bad really its just final fantasy has beautiful cut scenes, the game runs very well Smile
The beta client runs with no faults at all, the cgi scenes now work and the game runs perfectly, thanks for your help guys Cool

Users browsing this thread: 1 Guest(s)