Final Fantasy XII crashes on pcsx2 0.9.7
Hi, this is my fist time posting but I have been following up on many posts for a week now and I would like to say thanks for every ones efforts making this community possible.

Ever since my ps2 broke (system does not read cds) I haven't been able to play my old games, so I tried pcsx2. I was able to get the game function on full fps but I have hit a snag. Every time I use the license board to try and unlock something pcsx2 crashes. I can't make heads or tails of this and was hoping someone can help me out here.

My specs are:
Core 2 Duo [email protected]
4gbRam DDR3
ATI Mobility Radeon HD 3670

p.s. I use windows 7, if it helps.

Sponsored links

are you using any speedhacks?
try to remake your iso also with imgburn, be sure your dont mount it anywhere if you do.
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Yes, I am using all of the recommended speed hacks and the IOP x2 cycle rate hack that is not recomended.
Initially I only used the actual cd but that had problems with loading and all so I converted it to an iso and I didn't mount it.
Have you tried without speedhacks?
Even if some speedhacks are "recommended" they can still cause problems. They are just more compatible than others.
Also which pcsx2 version are you using, r3119? Or one you compiled yourself?

Edit: Wrong version number
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
I am using the r3113 version. Thanks for the advice I am going to tinker with the speedhacks a bit and let you know.
Thanks for the help everyone, it was one of the speedhacks that was causing the problem.
generally is. I use IOPx2 and EE1.5 and it seems to work fine, sometimes not though

Users browsing this thread: 1 Guest(s)