Finaru Fantageee XII
EDIT: Issue resolved! Smile

RE: GSdx
Hey all,

Final Fantasy XII (ntsc) related issue:

GSdx 0.1.7 = no slowdowns on Basche Flame Purge Quickening (and a few other spells), overall smooth and speedy (very speeeedy) but no hop-out-of-fullscreen mode implemented (DX9 and DX10) and bland visuals.

GSdx 0.1.8 and up = better postprocessing/fx/glow/visual shinies, but insane slowdown on Flame Purge Quickening (and a few other spells). Easy to hop in and out of fullscreen/window, not crashprone. Speedy, apart from 2 or 3 Quickenings/Spells.

I'm sure many of you have heard about this issue, it's litterally only the last 2 or 3 seconds of the Basche Quickening that it slows down to a halt.
Complex fx/scenes otherwise are just fine.

I've downloaded the GSdx pack at PCSX2, I've tested all versions, all SSE versions, current stable PCSX2 and alot of SVN's by using sstates and memcards but only 0.1.7 does not have the slowdown on forementioned spells.
The slowdown on 0.1.8 and above is stupidly insane, going from a stable (framelimited 60fps) to just 1-3 fps, which honestly harms the experience (especially when making minute-long Quickening chains).

My system:

CPU : i7 2600
GPU : Radeon HD4870 (DX10)
OS: Win7 64bit

Before going off on my videocard, it honestly isn't bad at all despite it's age, infact it's pretty fast on my system (apart from Skyrim where the fans go haywire) and emulation-wise, everything plays like a charm, including FFX. This issue is NOT related to my card Smile

So after all of the above, my question is, why is this (apparently) well-known issue issue?
After alot of new revisions/builds of GSdx, it still hasn't been fixed.
It's honestly not just a visual thing, it really hampers gameplay, which is a shame since it's only a very small piece that works like crap compared to the rest of the game, which is emulated in excellence on PCSX2 0.9.8 (and SVN's).

Sponsored links

Try the skidraw hack in GSdx.
Thanks, but "skidraw hack"? I've looked under speedhacks, gamefixes, the GS tab in Emulation Settings, but can't find it.
Exactly how do I enable it?

Thanks in advance.
Official 0.9.8 release: Find 'gsdx.ini' and add 'allowhacks=1' on its own line. Then open the GSDX control panel.
SVN build: In GSDX control panel, tick the 'Allow hardware hack' and you should find it.

I found Skipdraw (got confused because of rama's skidraw typo) and with value = 1 it solved the problem Laugh

FF12 is now properly playable for me, thanks guys.
Okay, I thought as much when you mentioned that GSdx 1.7 worked and 1.8 did not.
Gabest changed the behaviour from skipdraw always enabled to off back then.

That said, I bet that scene works fast enough even without skipdraw when a lower upscale factor is used (try x2).
With the limiter set to turbo 200%, framelimiter (F4) off, 1600x1050 stretch, Edge-Anti aliasing on, DX10 hardware, I reach 130-138 fps constant (unplayable, too fast), even through complex scenes, EXCEPT the Flame Purge Quickening's last 3 seconds will still hit 1-3 fps and my fans start blowing like mad. When the cast ends, all's good again.
I've tried native x2 / x 6 scaling before rama, before the skipdraw solution and that didn't work either.

Skipdraw value 1 does it for me and the game looks insanely good and smooth (framelimited at 60fps ofc), I might post a Youtube trueHD vid of this soon, just to e-peen around a bit Smile
The so-called HD vids I've seen of FF12 on youtube don't even come close.

I iz happy Smile
edge antialiasing is a software only feature, if you had read the title of the area its in
(06-14-2012, 03:02 AM)Squall Leonhart Wrote: edge antialiasing is a software only feature, if you had read the title of the area its in

You're correct. Must have been a remnant of me tweaking before getting the solution. In previous versions software options were grayed out in hardware mode.

Still, it doesn't change a thing concerning the rest of the options and the speeds I reach.

Users browsing this thread: 1 Guest(s)