Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fixing Death By Degrees PS2 Widescreen HD
#1
Hi everyone,

I'm trying to find the best and proper settings for the PS2 game Death By Degrees to be fully playable in widescreen HD.
Currently, the game looks phenomenal in HD however I'm having some minor random issues and problems that turn up at certain points of the game.

Minor issue: #1 The game randomly slows down. I think this happens mostly when there's a large amount of enemies on screen.
                    #2 The transition screens from door to door. Normally it's a fade, now it's more glitched out. This is a very minor issue.
                    #3 The blurry in-game cut-scenes. I read about this issue from other people playing different games, and I think it's because of the widescreen.

Current big issue: #4 For those familiar with the game, there is a part (around an hour in the game or more) when you must flee the ship and run to the chopper, only to get stung by some sort of drug, the game shifts to a cut-scene normally. What happens to me now is that the game completely crashes. The computer becomes unresponsive and/or completely slow. I had to restart the PC because I couldn't even get Alt-Ctrl-Del to work.


-----------------------------------------------------------------------------------------------------------------------

My Rig
- GeForce GTX 1070
- Intel Core i5-2400
- 8 GB RAM
- Windows 10

------------------------------------------------------------------------------------------------------------------------

Current PCSX2 Settings
- Video (GS) > Plugin Settings >
Adapter: NVIDIA GeForce GTX 1070
RendererL Direct3D11 (Hardware)
Interlacing: Auto

Allow 8-Bit Textures: OFF
Internal Resolution: 8x Native
Custom Resolution: Can't be changed ( 1024 x 1024 )
Texture Filtering: Bilinear (PS2)
Anisotropic FilteringL 8x
CRC Hack Level: Full (Safest)

-Enable  HW Hacks: ON >
Hacks Configuration: Everything is at ZERO or OFF, with the exception of Align Sprite and Alpha ticked ON. 

Software Mode Settings: Can't be changed
Shader Configuration: UNTOUCHED


--------------------------------------------------------------------------------------------------------------------------

I'd be incredibly grateful if someone can help me get this game running smoothly as I need it for recording.
Thanks so much!
Reply

Sponsored links

#2
With an internal resolution that high, likely story with the hard crash is you're running out of video memory. GSdx will start throwing warnings in all caps dark red text when this is first detected, but if you aren't fast enough, your entire system will start crawling. A few things to try for this:
- Play on 6x Native instead
- As the game approaches the slow down point, wait for said warnings to pop in the console, then very quickly open the GSdx plugin settings menu, and close it. There are some games such as Gran Turismo 4 which absolutely bully video memory, and oddly enough opening and closing the plugin settings menu will fix what we've come to call "VRAM spikes", because this stops and restarts GSdx. This one may or may not help in this case, but it's worth a shot.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#3
(03-25-2019, 04:18 PM)pandubz Wrote: With an internal resolution that high, likely story with the hard crash is you're running out of video memory. GSdx will start throwing warnings in all caps dark red text when this is first detected, but if you aren't fast enough, your entire system will start crawling. A few things to try for this:
- Play on 6x Native instead
- As the game approaches the slow down point, wait for said warnings to pop in the console, then very quickly open the GSdx plugin settings menu, and close it. There are some games such as Gran Turismo 4 which absolutely bully video memory, and oddly enough opening and closing the plugin settings menu will fix what we've come to call "VRAM spikes", because this stops and restarts GSdx. This one may or may not help in this case, but it's worth a shot.

I will try this ASAP and put an update! 
And thank you!
Reply
#4
So I just set the settings on 6x Native and the game managed to load the cut-scene (although it took some time) however it wasn't able to load the battle screen, which crashed resulting in completely freezing my computer. I wasn't able to detect any red text warnings.

I rebooted and instead I tried 4x Native and  4x Anisotropic Filtering; the result was a much smoother and shorter transition from in-game cut-scene to the actual cut-scene. I could barely see the difference in quality.

However another issue is, when I come to the next battle screen, the game looks disastrous and performance is slower. Opening the menu and select screen the game looks perfectly fine, but during this very short ''hallucination'' boss fight the game almost looks like a prototype. 

I attached images.

Trying Renderer (Software) makes the game work perfectly fine but the quality drops
Trying Renderer (Direct3D9 Hardware) Makes the game a little bit better, still slow.


Attached Files Thumbnail(s)
           
Reply
#5
Anyone has any idea how I can fix the above issue?
Reply
#6
First you should upgrade to 1.5.0. Click the link below
Reply
#7
(03-29-2019, 03:09 AM)CK1 Wrote: First you should upgrade to 1.5.0. Click the link below

Many thanks for the reply.
There's a long list of 1.5.0, I assume I can download any one of these correct?
And another thing is, it says Windows 32bit whilst my PC is 64bit. Does it make a difference?

***
I managed to download it and will be trying the game again
Reply
#8
So I downloaded the 1.5.0 PCSX2 (first one on the list) and I have these current settings, picture below. I have't really tempered with other settings.
The internal resolution Native to Native x3 (1080p) makes this part of the game smooth but still looking bad. I played the game normally on Native x4 even x8 but this part becomes incredibly slow and prone to freezing my pc.

However, the game retains the glitchy scene on whatever internal resolution.


Attached Files Thumbnail(s)
   
Reply
#9
Switch to OpenGL since you have a nvidia card.
Reply
#10
(03-30-2019, 07:32 AM)CK1 Wrote: Switch to OpenGL since you have a nvidia card.

So I switched to OpenGL and this is what I get.
Also, note Log window warning saying VRAM is very low.


Attached Files Thumbnail(s)
   
Reply




Users browsing this thread: 1 Guest(s)