Flickering FMVs in FFX
Hello everyone. I am receiving flickering FMVs in FFX. The game runs flawlessly the entire rest of the time (minus a few graphical oddities; strange transparencies and a few black textures on some models), it's just the second that an FMV begins the screen will flicker, not only that, but around 20% of the right edge of the picture is distorted; it looks like it is being sucked from the rest of the cutscene (it's odd)...they are pretty much unwatchable. I can usually remedy this by either: 1. Save State and immediately Load State, or 2. Save state, exit, and watch the cutscene with the DX Software renderer.

Now, for my pertinent stats:
Q9400 @ 3.4, 4gb Ram, Win7 64, Nvidia GTX 260.
I'm running PCSX2 Beta r1888 (the recommended installer from the PCSX2 website). I've tried both sets of plugins, the ones that come stock with the installer and the newer March 11th 2010 Beta plugins, no change.
I am using the USA version of FFX (in .iso form).

As for my PCSX2 configuration, I've literally tried turning everything off one at a time to see if that has been the culprit. My method was to untick and option, load up a save state during an FMV and see if the flickering/odd distortion was still occurring, nothing has changed. Here's my current, (normal) configuration:
Graphics: Using GSdx 1873 (SSE41) 0.1.15
Resolution: 1920x1080 60Hz, Renderer: D3D 10 (Hardware), No Interlacing, Ratio:16:9, Internal Res: 2560x2048, everything else but VSync checked.
CPU: EERec Checked, VU0/1rec both checked, both microVUs checked, Multi threaded GS Mode checked
Speed Hacks: Default Cycle Rate, all EE hacks checked, both VU hacks checked, and VU Cycle Stealing (the third notch) enabled.
Advanced: I use the defaults.

Let me know if you need more information, or if you know of a fix for this problem, thanks.

Sponsored links

You're using speed hacks, disable them.
[Image: newsig.jpg]
(04-28-2010, 09:17 PM)Bositman Wrote: You're using speed hacks, disable them.

I've loaded into an FMV with all the speed hacks disabled, still get the flicker. Is that because of loading a save sate?
Most likley. Try using a a real save.
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
im no expert but i recomend you to try to delete your plugins and put this one instead
choose GSdx 2693 (MSVC 15.00, SSE2) 0.1.16
atleast this is how it works with me
if didnt work, you should visit this page it realy helps
Ok, now I've turned all the speed hacks off and loaded up a normal save. Some of the FMVs play fine, but after a while they will begin to flicker again, and this time they will start to slow down and eventually give me a black screen and crash the emulator.

In my dos box I get 'GSDX m_merge is null'. Any ideas?
That's pretty weird...are you using the GSdx ScarMoh suggested above? Also try setting it to DX10 Software see what happens then
[Image: newsig.jpg]
Right before I posted I cleared my plugins dir and re-downloaded the latest from the thread Scar linked...it messed up my sound so I had to revert that to an older driver, but it all loaded up and still gave me the funky FMVs.

Setting to software solves the problem, but then I have to play the game in ugly native res, which kinda defeats the purpose of running it on my PC.

Any idea what 'm_merge is null' is signifying? It's repeating to infinity in my dosbox when the FMV crashes, and I can't find anything on the internet about it.
It's a GSdx error, one which should NOT be happening even. You can always switch back to hardware renderer when the video has ended...
Hmm maybe this is an ISO problem. Can you try ripping it again from your DVD using imgburn? Then run it by using Linuz ISO (do NOT mount it with any external program)
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)