Footfall sound issues in Rule of Rose PAL
#1
Hi there. I have detected problems in the sound of the protagonist's footsteps in Rule of Rose, only in the PAL version. In the NTSC version the footsteps sound is reproduced correctly, however, in the PAL version the footsteps sound stops playing after a few seconds. Then the sound of footsteps comes back and then goes out again.

Tested on various versions of PCSX2 and on various computers.

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
#3
Attach the last lines of the file emulog.txt:
Code:
rxfile : device changed 1
open fail name ¥DATA¥CMNTEX¥LOAD_EU.BIN;1
rxfile : disk type = 20
rxfile : completed to read sector '16'
rxfile : completed to read sector '257'
rxfile : completed to read sector '262'
rxfile : failed to open file 'data/options.txt'
rxfile : completed to read sector '266'
rxfile : completed to read sector '267'
rxfile : completed to read sector '283'
rxfile : completed to read sector '269'
rxfile : completed to read sector '281'
rxsnd : SPU heap alloc 00005010 - 0007F0CF (499904) left 1314608 / 1814512
snddrv : open XVAB '0'
         header - IOP : $000C1200 - $000C2708 ( 5384 )
         body   - SPU : $00005010
rxsnd : SPU heap alloc 0007F0D0 - 00085A0F (26944) left 1287664 / 1814512
snddrv : open XVAB '1'
         header - IOP : $000C2800 - $000C2E58 ( 1624 )
         body   - SPU : $0007F0D0
rxfile : completed to read sector '364'
rxfile : completed to read sector '264'
rxsnd : SPU heap alloc 00085A10 - 00089A0F (16384) left 1271280 / 1814512
rxsnd : open ADPCM '47'
        IOP   000C2F00 - 000C6F00 ( 16384 )
        ADPCM 00085A10 - 00089A10 ( 16384 )
rxfile : completed to read sector '288'
rxfile : completed to read sector '289'
rxfile : completed to read sector '290'
rxfile : completed to read sector '291'
rxfile : completed to read sector '292'
rxfile : completed to read sector '293'
rxfile : completed to read sector '294'
rxfile : completed to read sector '295'
rxfile : completed to read sector '296'
rxfile : completed to read sector '297'
rxfile : completed to read sector '298'
rxfile : completed to read sector '299'
rxfile : completed to read sector '300'
rxfile : completed to read sector '301'
rxfile : completed to read sector '302'
rxfile : completed to read sector '303'
rxfile : completed to read sector '304'
rxfile : completed to read sector '305'
rxfile : completed to read sector '306'
rxfile : completed to read sector '307'
rxfile : completed to read sector '308'
rxfile : completed to read sector '309'
rxfile : completed to read sector '310'
[seek]: data/snd/xws/s100000.str (6936128Bytes)
rxsnd : SPU heap alloc 00089A10 - 0008BA0F (8192) left 1263088 / 1814512
rxsnd : open ADPCM '46'
        IOP   000C6F00 - 000C8F00 ( 8192 )
        ADPCM 00089A10 - 0008BA10 ( 8192 )
rxsnd : SPU heap free (1279472 / 1814512)
rxsnd : SPU heap free (1287664 / 1814512)
rxfile : completed to read sector '379'
rxfile : completed to read sector '352'
rxfile : completed to read sector '277'
rxfile : completed to read sector '286'
rxsnd : SPU heap alloc 00085A10 - 000E8B8F (405888) left 881776 / 1814512
snddrv : open XVAB '2'
         header - IOP : $000C2F00 - $000C4A48 ( 6984 )
         body   - SPU : $00085A10
rxsnd : SPU heap alloc 000E8B90 - 0010D30F (149376) left 732400 / 1814512
snddrv : open XVAB '3'
         header - IOP : $000C4B00 - $000C507C ( 1404 )
         body   - SPU : $000E8B90
rxsnd : SPU heap alloc 0010D310 - 0015F88F (337280) left 395120 / 1814512
snddrv : open XVAB '4'
         header - IOP : $000C5100 - $000C5D90 ( 3216 )
         body   - SPU : $0010D310
rxfile : completed to read sector '266'
rxfile : completed to read sector '269'
rxfile : completed to read sector '264'
rxsnd : SPU heap alloc 0015F890 - 0016388F (16384) left 378736 / 1814512
rxsnd : open ADPCM '46'
        IOP   000C5E00 - 000C9E00 ( 16384 )
        ADPCM 0015F890 - 00163890 ( 16384 )
rxsnd : SPU heap free (395120 / 1814512)
rxsnd : SPU heap alloc 0015F890 - 0016388F (16384) left 378736 / 1814512
rxsnd : open ADPCM '46'
        IOP   000C5E00 - 000C9E00 ( 16384 )
        ADPCM 0015F890 - 00163890 ( 16384 )
rxsnd : SPU heap free (395120 / 1814512)
rxfile : completed to read sector '378'
rxfile : completed to read sector '283'
Closing plugins...
    Closing DEV9
    Closing FW
    Closing USB
    Closing CDVD
    Closing SPU2
    Closing PAD
    Closing GS
Delete 0 Shaders, 34 Programs, 28 Pipelines
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
(GameDB) Unloading...
#4
The sound seems to be fine on the latest development builds from what I can tell (although I'm using NTSC so maybe not the best ) but we have fixed a bunch of sound stuff since 1.6, please grab it from here: https://buildbot.orphis.net/pcsx2/
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#5
I downloaded the latest build and the result is the same. It only fails in the PAL version.
#6
You're right, not sure why that's happening, but it seems to just give up making footstep noises while you're running, then a second later starts doing it again, very odd.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#7
Are you sure that doesn't happen on a real ps2? Watched some real system videos, and the steps sounds seem off on them, like this one which says it's running on a Spanish ps2:

https://youtu.be/todecxlz0wU?t=378
#8
(09-29-2021, 02:38 PM)K.F Wrote: Are you sure that doesn't happen on a real ps2? Watched some real system videos, and the steps sounds seem off on them, like this one which says it's running on a Spanish ps2:

https://youtu.be/todecxlz0wU?t=378

well the step sounds are comical anyway, they don't match up with your feet, but on the EU one on the emu it plays like 3 footsteps, goes silent for 1 second or so, then plays 3 more footsteps, and so on. you can't really hear the footsteps at all in that video
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#9
Okay, thanks for proving you've never played this on a console Smile


One of our contributors has the game and recorded it running on his console for me, and guess what? the step sounds are broken there too.. You can watch it yourself https://cdn.discordapp.com/attachments/6...537859.mp4
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!




Users browsing this thread: 1 Guest(s)