Forbidden Siren 2 - Flashback Bug

While playing a mission for Akiko Kiyota with first Flashback usage I'm unable to see the flashbacks. I'm trying to enable sightjack when some noise appears for less than one second, and when I think I try it in time, I see something uncommon for very short moment, and then it just disappears and I see just sightjack noise.

How should flashback work actually in these moments? Is it known bug of emulation? I think, when I catch the flashback, it should be seen for enough time to understand everything it should show.

FB explanation in walkthrough:

Quote:Forced tutorials:
Not much this time, fortunately.

--- "'Akiko Kiyota' has the special power of 'Flashback.'"
"When entering a particular spot, there's a brief on-screen change."
"Upon seeing the change, attempt to Sightjack."
"You may be able to see the remnants of somebody's past memory."
"As you search various areas, try to find areas which hold old memories."

Sub-target: Acquire a key using 'Flashback.'

The different flashbacks:

- Near the playground - some child playing with a robot toy.
- Inside the B-Building's first floor stairway corridor (the west side)
- a note with an image of a key on it.
- Inside the A-Building's first floor stairway corridor (east side) - a note
with an image of a robot in it, also the number '203'.

Thank you

Sponsored links

Anyone played it at all?
go try latest SVN build(pcsx2 latest version)
try GSDX software mode.
Same result. Something appears on very short period, 100-300ms, and then just noise.

Has anyone there used that flashback successfully on emulator or PS2? Maybe I'm just trying to use it incorrectly?
Have a memorycard close/before of it?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
@leet i heard its a known bug for this game on hasn't been fixed.....and what about the killer sps in tnis game....didn't see those or are they fixed in the latest svns.???
Found the solution. I've been trying to use flashback incorrectly. When you see noise, you should (not instantly, but without walking out) enable sightjack and try to find some channel shown in sepia. Two of three flashbacks needs software mode to see something except brown background. It's hard to find it using keyboard, you may need to turn a bit before you will be able to catch the direction.

What I've seen as short flashes were just first-person look pictures, maybe that's a bug.

Another well-known bug for this game of jumping polygons up and down - yes, it's still not fixed in last build.

Users browsing this thread: 1 Guest(s)