Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frame Rate and Graphical Quirks with Mercenaries - PoD
#1
Hello, I am quite new to PCSX2 and Emulating so please forgive my ignorance in parts. Much like other users in other games, I've been experiencing some frame rate slowdowns (and subsequent audio slowdowns with it) that are quite jarring for the game play experience and quite surprising given my PC specs. Obviously during "busy" moments in the game like skirmishes and gunfights, explosions, smoke elements etc, my emulator performance can often drop anywhere from 95% to 40%. Ill post my PC specs below. 

Windows 10 - 64bit PC
CPU - Intel Core i5-7600K (4 Cores) @ 3.80Ghz 
Motherboard - ASUS Prime Z270-K
GPU - EVGA GeForce GTX 1070 - 8GB
RAM - 16GB of installed RAM


I also have been noticing some strange lacing issues on the screen during the opening menu sequence and during regular gameplay too. I'll post them in the attachments below.

Also Attached are my current emulator settings/plugins and configurations that I have set for the game, I am currently using PCSX2 v. 1.4.0. In my relative inexperience with this, I would appreciate any and all advice/recommendations as to what can be done to fine tune or at least solve the issues I have been experiencing while playing PoD. However, if at the end of the day it all boils down to the the capabilities of my PC causing the performance issues I've been experiencing, then so be it I suppose! Thank you.


Attached Files
.jpg   Mercenaries Troubleshoot 1.jpg (Size: 45,86 KB / Downloads: 17)
.jpg   Mercenaries Troubleshoot 2.jpg (Size: 27,06 KB / Downloads: 13)
.jpg   2019-11-09 22_44_55-Window.jpg (Size: 40,92 KB / Downloads: 14)
.jpg   2019-11-09 22_45_29-Window.jpg (Size: 39,45 KB / Downloads: 11)
.jpg   2019-11-09 22_48_21-Window.jpg (Size: 53,25 KB / Downloads: 12)
.jpg   2019-11-09 22_48_44-Window.jpg (Size: 42,79 KB / Downloads: 12)
Reply

Sponsored links

#2
Nick Woodbury Wrote:Hello, I am quite new to PCSX2 and Emulating so please forgive my ignorance in parts. Much like other users in other games, I've been experiencing some frame rate slowdowns (and subsequent audio slowdowns with it) that are quite jarring for the game play experience and quite surprising given my PC specs. Obviously during "busy" moments in the game like skirmishes and gunfights, explosions, smoke elements etc, my emulator performance can often drop anywhere from 95% to 40%. Ill post my PC specs below. 

Windows 10 - 64bit PC
CPU - Intel Core i5-7600K (4 Cores) @ 3.80Ghz 
Motherboard - ASUS Prime Z270-K
GPU - EVGA GeForce GTX 1070 - 8GB
RAM - 16GB of installed RAM


I also have been noticing some strange lacing issues on the screen during the opening menu sequence and during regular gameplay too. I'll post them in the attachments below.

Also Attached are my current emulator settings/plugins and configurations that I have set for the game, I am currently using PCSX2 v. 1.4.0. Overall, in my relative inexperience with this, I am looking for any and all advice as to what can be done to fine tune or at least solve the issues I have been experiencing while playing PoD. If, at the end of the day it all boils down to the emulation causing the issues I've been experiencing earlier in my post, then so be it I suppose! Thank you.

Try default setting, you should be able to get 100% speed which I can reach 100% speed on a slighty
slower cpu than you. You should also use build 1.5 pcsx2 emulator.
OS: Windows 10 Pro 64 BIT N
CPU: Intel I7-6700 3.4 GHZ
GPU: Gigabyte GeForce GTX 1050 TI
RAM: Crucial 2400MHZ 2x8GB DDR4
Mainboard: Asrock H270M PRO4
Display: Asus VP228
Audio: Realtek 892 High Definition Onboard Audio
Storage: Seagate Desktop 1TB HDD, Samsung 120GB SSD
Optical: HL-DT-ST&Prod_DVD-RAM_GHC0N
Power supply: Corsair VS550 Watts
Reply
#3
[attachment=69792 Wrote:sportster pid='603878' dateline='1573358980']
Try default setting, you should be able to get 100% speed which I can reach 100% speed on a slighty
slower cpu than you. You should also use build 1.5 pcsx2 emulator.

Thank your Sportster. I had no idea there was a 1.5.0 version out there since the PCSX2 download page only offered 1.4.0 as the latest. Upgrading to 1.5.0 fixed all the issues I have been experiencing in my first post, the game runs very smoothly with no slowdowns in frame rate or emulator performance! 

The only problem left to conquer is the common Frame Buffer Conversion hack that removes the horizontal post-processing lines during game playing and exaggerated when the pause menu up https://github.com/PCSX2/pcsx2/issues/2376 . Unfortunately my version of 1.5.0 does not have an option in my hardware hacks config to enable a Frame Buffer Conversion hack that is mentioned in the forum that I linked. 

Any recommendations?


Attached Files
.jpg   2019-11-10 13_46_33-Window.jpg (Size: 19,14 KB / Downloads: 15)
Reply
#4
Quote:The only problem left to conquer is the common Frame Buffer Conversion hack that removes the horizontal post-processing lines during game playing and exaggerated when the pause menu up https://github.com/PCSX2/pcsx2/issues/2376 . Unfortunately my version of 1.5.0 does not have an option in my hardware hacks config to enable a Frame Buffer Conversion hack that is mentioned in the forum that I linked. 

You're still using an outdated build or plugins. You should install 1.5 properly in a new location.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply




Users browsing this thread: 1 Guest(s)