Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frame rate dip and then back to normal over and over
#11
Wow, what a supportive forum thank you everyone for your help!

I will implement these suggestions tonight (I'm a work now) and let you know if there is improvement.
Reply

Sponsored links

#12
Ok good news, there has been some improvement!

Now when the frame rate dips its going down to about 45-50fsp (normally 60) and recovering faster.

Here is what I have done so far:
- Lowered the game rez to 800x600
- Turned on MTVU
- So far I've left the speed hacking off, but I'm going to play with that next.

(11-04-2014, 06:30 PM)s.sakash Wrote: try sw mode +3 threads but, if it just drops for some time , it's mostly a chance of bad rip. did you try playing with the cd if you had the same slowdown for a while without corresponding to the load of textures.

Could you please explain where I can turn this feature on I'm looking for it but I just can't find it.

Also I will try using my original Castilvaina CD and see if it helps.
Reply
#13
(11-03-2014, 07:58 AM)jesalvein Wrote: from what I see, your CPU might be the problem. What do the EE% & GS% say when getting slowdowns ?
You have no idea how demanding pcsx2 can be.

When there is a slow down the EE is at close to 100% and the GS goes up to to between 40 to 50%

When things are not slowed down the EE is around 40 to 50% and the GS is around 15 to 30%
Reply
#14
(11-04-2014, 09:58 PM)johnyct9760 Wrote: Ok good news, there has been some improvement!

Now when the frame rate dips its going down to about 45-50fsp (normally 60) and recovering faster.

Here is what I have done so far:
- Lowered the game rez to 800x600
- Turned on MTVU
- So far I've left the speed hacking off, but I'm going to play with that next.


Could you please explain where I can turn this feature on I'm looking for it but I just can't find it.

Also I will try using my original Castilvaina CD and see if it helps.

He's talking about software rendering mode, which, unless you need it for this game, probably won't help.
You said EE load goes to 100% during slowdown, that means your cpu is the bottleneck. This also means you can probably run 2-3 times native resolution without it affecting performance.

Anyway, under speedhacks turn on mtvu and see if setting ee cyclerate or vu cycle stealing up one notch helps. Those settings can often improve performance without any real side effects, so you should at least try them.

You also want to make sure you're using the GSdx DX11 hardware mode under config -> video -> plugin settings - > renderer.
Might as well make sure allow 8 bit textures is off, that can help performance a bit too.
Reply
#15
I added a few speed hacks along with the suggestion on this forum and not things are running great thank you all for the help!
Reply
#16
(11-06-2014, 01:47 AM)johnyct9760 Wrote: I added a few speed hacks along with the suggestion on this forum and not things are running great thank you all for the help!

i think you mentioned now as not, anyway glad that using speedhacks helped you Smile and, don't try pushing speedhacks to it's full extent since, it could often cause some issues.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction
Reply




Users browsing this thread: 1 Guest(s)