Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Framerate issues - FFXII
#1
Seems alot of people have issues with this game?

Just set up 0.9.7 using the guide and the game loads up albeit laggy and with some dodgy sound but when I start a new game, go through the setup options and then click 'begin game', the screen goes black and my pc crashes. I can't seem to keep a smooth framerate at all, even in menus.

Windows 7 64bit
3gb ram
Intel i3 @2.3ghz
Intel GMA HD

GSdX 3693 0.1.16 SSE3 - Direct X10 Hardware, Native resolution
SPU2-X 1.4.0
Gigahertz CD/DVD Plugin 0.7.0 (although i'm loading the game from an ISO ripped from my DVD)

Only speedhack was EE Cyclerate at 2 which helped improve the framerate of the initial intro video.

I'm assuming my graphics aren't up to par right? Does anyone know any tweaks I could use to improve performance or should I just give up trying emulation on this laptop?

Sorry if I forgot any info! Thanks for the help Smile

EDIT: I've fixed the crash, i just had to change to DX9 and it loads up fine but nothing I do seems to fix the framerate and sound issues. I'm using the PAL version and i'm only getting 30FPS giving the game a sort of slow motion effect when I play. Any ideas? Changed my resolution as well to 640*480 with a x2 set instead of native

Reply

Sponsored links

#2
max out the VU cycle stealing and EE cyclerate and enable the recommended speedhacks
EDIT: I always like going up to the maximum speedhacks and going down from it. Most people might say go up step by step.
Reply
#3
Cheers for the reply, tried what you said but still getting the same results, around 30FPS slow motion gameplay.

EDIT: Tried going down from max, it seems that I can't go past a specific framerate. I've noticed when i place the character in a corner, camera facing away from the open area (so there's not much on the screen) framerate shoots up to max so i need a way to boost rendering i'm guessing
Reply
#4
Native resolution will always be faster. Make sure you're using the recompiler instead of the interpeter and Take a step back on the VU cycle stealing.
Reply
#5
Intel integrated videocard (as onboard video cards in general) is not good to play 3D games. The CPU is a tad slow too... it will be almost impossible to run that game at full speed in this laptop.

You can, and must, try speedhacks combination to find one wich gives you the best possible results, maybe trying frameskip can help too.
Imagination is where we are truly real
Reply
#6
I'll have a shot at frameskipping. Switched back to native resolution and same results as when I had it on 640*480 x2, i think i've found the limit Sad haha
Reply
#7
You really shouldn't ever have VU cycle steal turned all the way up. Even if you do get better FPS displayed, gameplay will either be slowed down or be graphically glitchy as heck.

As for your question neither your GPU or CPU are very good for PCSX2... but if you want to know exactly what's causing the most problem check the top of the game's window. There are 2 %'s there. One will say EE, the other will say GS. If EE is the one maxing out (between 80-99% most of the time) it's your CPU that's the bottle neck. If the GS is maxing out, then it's your integrated graphics.

If it's your graphics, the only thing you can try doing is turning the internal res to native. It won't look as good but should give a nice boost but still be too slow.

If it's your CPU... the only thing you can do is try more speed hacks, but there is only so much speed hacks can do.

The recommended PC specs for PCSX2 are a dual or greater core processor clocked at 3ghz or higher. The higher obviously the better. You can get away with less for some games (especially 2d ones) but 3d ones especially require the higher speed to maintain a solid high frame rate.
Reply
#8
(04-24-2011, 05:53 PM)Koji Wrote: You really shouldn't ever have VU cycle steal turned all the way up. Even if you do get better FPS displayed, gameplay will either be slowed down or be graphically glitchy as heck.

As for your question neither your GPU or CPU are very good for PCSX2... but if you want to know exactly what's causing the most problem check the top of the game's window. There are 2 %'s there. One will say EE, the other will say GS. If EE is the one maxing out (between 80-99% most of the time) it's your CPU that's the bottle neck. If the GS is maxing out, then it's your integrated graphics.

If it's your graphics, the only thing you can try doing is turning the internal res to native. It won't look as good but should give a nice boost but still be too slow.

If it's your CPU... the only thing you can do is try more speed hacks, but there is only so much speed hacks can do.

The recommended PC specs for PCSX2 are a dual or greater core processor clocked at 3ghz or higher. The higher obviously the better. You can get away with less for some games (especially 2d ones) but 3d ones especially require the higher speed to maintain a solid high frame rate.

35 games and no crashes hangs occured from maximum VU cycle stealing. Most games have great speedups. A few of my games run better at 2. And Disable framelimiting. A few tolerable stuff happen
Reply
#9
I think i'll just accept that my laptop can't handle running this game at a decent framerate. The EE and GS percentages were both at around 80% when the framerate was chugging at 30FPS so I doubt I can do much to make it playable. Thanks for all the help guys, it's much appreciated!
Reply
#10
Orchlon: I never said crash or hangs did I? I can guarantee you though that VU cycle stealing IS causing the games to run slower than they would on a real PS2 or causing some sort of graphical mischief. I've run many games myself and all have been effected on some level with VU cycle steal set to max, that's why it's not a recommended speed hack... You're basically running your emulated PS2 at half speed when you use it and EE cycle hack at the same time.
Reply




Users browsing this thread: 1 Guest(s)