Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Front Mission 4, upscaling problems
#1
There are two problems that come from up scaling, Im using x3 because it looks pretty nice, while at native it looks too pixelated.

The problems are that shadow size are up scaled too, making the shadows very big. The other problem is that in game scenes look very blurry, but the blur disappears when the camera is moving. Again, without up scaling, there is no blur at all.

Is possible to fix this?

Thanks you
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.
Reply
#3
Here is a screenshot of the blurriness. It seems that it only happens in "cinematics" (game videos). I said its gone when I move the camera but its not true, I think  it just an optical effect.

http://postimg.org/image/z3y25k33v/

Here a screenshot of the shadows. In this case for some reason the shadow was in the correct size, but its corrupted, it fills everything that it touches like if it was a brush with paint. In another mission the shadow was very big.

http://postimg.org/image/5amgj7p2z/


Attached Files
.txt   emuLog.txt (Size: 7,13 KB / Downloads: 106)
Reply
#4
can you try using the latest development build ? http://buildbot.orphis.net/pcsx2/index.php
Reply
#5
Got the pcsx2-v1.5.0-dev-415-g236e5fc-windows-x86

The shadows went worse:
http://postimg.org/image/s204jczi3/

I tried with native resolution but they are also corrupted.
Reply
#6
Have you tried OpenGL? The last image you posted shows you are using Direct3D 11 hardware mode.  Also give Preload data frame a try along with Safe Accurate blending and blending unit accuracy along with hardware depth and accurate date and try them in different combinations and see if anything helps.
Reply
#7
Yes, I tried everything, like a chicken running around without its head (thats why directx and opengl and...). Preload data needs round sprite and sprite option below it? Anyway, I tried it too with full both along with the rest of options that you said.

The shadow corruption persists.
Reply
#8
Hmm, could you try a custom resolution of 1152 X 1344 ? just to check whether the bug is related to the RT buffer size handling.
Reply
#9
I tried but nothing changed.
Reply
#10
(03-09-2016, 03:34 AM)JohnE Wrote: I tried but nothing changed.

Then I assume it's a valid issue with upscaling on the emulator. could you check whether Half-pixel offset hack fixes it ?
Reply




Users browsing this thread: 1 Guest(s)