Front Mission IV (SLUS_208.88) frame cap?
Some weird thing with FM4;

For some reason pcsx2 caps the frames of my NTSC iso of Front Mission 4 to 50fps. No matter what I change, speedhack, renderer, sw/hw mode, plugin or otherwise, in many screens the framerate is just capped to 50.

The only way to change it is to uncap the frames altogether (F4) which results in 70+ frames which is altohether too fast again.
The frustrating thing is that my pc can keep up while juggling 5 basketballs and and peeling 20 kilos of potatoes EE/GS/VU under 50%.
Check the's kinda sad.

Anyway, does anyone know why this is or have have the same issue?

Short specs:
Windows 7
PCSX2 r5350
Gsdx32 r5334 (sse4)
DX11 plugin

All settings default.

Attached Files Thumbnail(s)

Sponsored links

this occurs in some cases when the game is launched from a PAL bios for a handful of titles

does it occur if the game is executed via quick/fast boot.
It happens in both full/fast boot.

And no matter which NTSC Bios I use (I have tried all 4). It boots fine at 60fps, as it should for NTSC and then as soon as I load my game it drops to 50fps cap.
When I am in a fight or at certain cutscenes it temporarily increases again to 60fps. Its just inconsistent and I'm stumped to remedy it by myself.
4 bios versions? :/
this sounds like intended game behavior then.
Judging by the behavior of the music and voices I don't think so. They have a definite "slow-mo" sound to them...

- When browsing weapon parts it's 60fp[s
- As soon as I leave that screen is slumps back to 50fps
The change in music tempo is just too odd to be intended.

Maybe it's a side-effect of some "special use" of the ps2 engine that causes the emulator to interpret the instructions as such?

While it's definitely not a game-breaker I do think it merits further investigation. I'm ready to help in any way I can...non-decompiler stuff that is.
or it could be the use of a prepatched pal conversion causing issues for the game timing -_-
have you tried re-ripping the game? so you can start with a clean iso.
This is a clean un-cracked/patched iso. I guess the crc would have failed if it wasn't. It shouldn't matter whether I rip with daemontools or alcohol, right? I've ripped my entire collection as such without problems so far.

In any case, it's doesn't seem to be a settings issue, as I had naively hoped. I'll just play through as it is. Perhaps I'll make a real bug report but I doubt it will get a high priority.

Thanks for all the pointers though! Laugh

Now, back to slam-dunking some more wanzers.
Sounds a bit like the frame cap issue in that Street Fighter game. Basically this is a combination of VSync and weird update rate.
Try to force VSync off everywhere you can (also disable Windows Aero by using a "basic design").

Users browsing this thread: 1 Guest(s)