Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frustrating loss of performance with Win7 x64
#31
(06-01-2011, 12:38 AM)Squall Leonhart Wrote: the only othing suggestion i have is that it could be core parking or turbo related.

Isn't core parking related to quad cores only? I have a dual core.

Maybe I should try and play with the turbo settings...
Reply

Sponsored links

#32
beardsleybob, please read this first, and if that doesn't help, open a new thread. This thread deals with a specific issue which is not related to yours. Thank you.


(06-01-2011, 01:54 AM)themanuel Wrote: Isn't core parking related to quad cores only? I have a dual core.

Maybe I should try and play with the turbo settings...
Is it possible that on one of your OSs the CPU and/or the GPU are overclocked via some app which dynamically modifies the clocks? (like Easy tune, etc)

You can use CPUz and GPUz to display/log the clocks frequencies. It might help.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#33
(06-01-2011, 01:54 AM)avih Wrote: Is it possible that on one of your OSs the CPU and/or the GPU are overclocked via some app which dynamically modifies the clocks? (like Easy tune, etc)

I use RivaTuner to overclock the GPU on both OS's and it is a fixed O/C. However, the problem occurs both on interpreter and recompiler modes for VU emulation.

I also O/C the CPU through the BIOS so it affects both OS's and it is also a fixed amount.
Reply
#34
(06-01-2011, 01:54 AM)themanuel Wrote: Isn't core parking related to quad cores only? I have a dual core.

Maybe I should try and play with the turbo settings...

Core parking is supported on any processor that can achieve the C6 state, and given your processor supports turbo, i expect it does since C6 is required for the 2nd stage turbo (single core turbo)

Windows XP does not support turbo mode properly, so that'd explain why performance wasn't nuked there.

Theres several users on here who have found turbo screws up the pcsx2 performance.
Reply
#35
(06-01-2011, 02:08 AM)Squall Leonhart Wrote: Core parking is supported on any processor that can achieve the C6 state, and given your processor supports turbo, i expect it does since C6 is required for the 2nd stage turbo (single core turbo)

Windows XP does not support turbo mode properly, so that'd explain why performance wasn't nuked there.

Theres several users on here who have found turbo screws up the pcsx2 performance.

Oh, I thought turbo was a function of the emulator itself. If this is a very modern feature, chances are I don't have it as this is an E4xxx series CPU from 2007. A quick glance on the web shows me this is Core iX feature so I think it would not apply to me. I can see both cores working hard on the task manager when I run PCSX2.
Reply
#36
ah, well going back that far, i don't think it has either turbo or C6

windows could be having issues with the thread scheduler i suppose.
Reply
#37
(06-01-2011, 01:30 AM)beardsleybob Wrote: [...]with Intel i3, Intel HD graphic card with (I think) 1.68GB RAM on it.

well...if it´s really an intel hd graphic card you should be happy about that "much" of fps...because onboard graphic cards use as far as i know a part of the ram when they need more space...(shared memory) also i only knew of one i3 from a friend...his i3 had always slowdons...i think he didn´t turned on all cpu functions, like always running the cpu at max percentage (there are powersaving options to reduce the cpu speed if it isn´t needed)...also the amount of your ram is strange...because i don´t know any kind of the ddr3 (which i think you have) that has less then 1gb per slot...so i guess it´s that shared memory graphic card thing...
and that will be one of your biggest problems...
Reply
#38
Update on what I know, after many trials:

Soul Calibur III, in-game, Ivy vs Setsuka (or whatever):
- Win XP: ~80% GS
- Win 7: ~60% GS
- GeForce 8500 GT vs GTS 250: no difference
- Numerous GeForce drivers: no difference
- Different video plugins, DX9 vs DX10, etc.: no difference
- Video plugin set up for software mode: Win XP faster by about the same
- Other emus, for reference:
- Dolphin 32 bit: slower as well by ~20% in Win 7 vs Win XP
- Dolphin 64 bit: faster than 32bit in Win XP by ~10%
- Obviously can't compare Dolphin 64 bit in Win XP vs Win 7
- MAME 32 bit: exact same performance in both OS's
- MAME 64 bit: ~20% faster than 32 bit

I'm starting to get the feeling that the problem is with emulators that actually use the video card. However, the problem is not video card horsepower or the GTS would have made a difference. This must have to do with the way Windows 7 interacts with the video card. However, this does not explain why the game is still faster in XP when running the video plugin in software mode.

I'm starting to wonder if I should stay with Windows XP, but I need the extra performance of MAME64 in some games.
Reply
#39
(06-02-2011, 02:44 PM)themanuel Wrote: - GeForce 8500 GT vs GTS 250: no difference
sorry but i think that is IMPOSSIBLE XD i mean...8500gt vs gts 250...o.O
something must went horribly wrong on your machine...because the 8500 is no challenge lol...o.O
hm even if it has nothing to do with win itself...can you look in your bios if theres an option which graphic slot is checked first? (something like onboard, pci-e, pci can be chosen there)
maybe theres something in your bios wrong o.O
Reply
#40
(06-02-2011, 03:56 PM)TheNewGuy Wrote: sorry but i think that is IMPOSSIBLE XD i mean...8500gt vs gts 250...o.O
something must went horribly wrong on your machine...because the 8500 is no challenge lol...o.O
PCSX2 does not use the video card as much as you think. Even my 8500 GT is not even utilized at 50%. Download GPUz and monitor your video card usage while running a game in PCSX2. You'll be surprised at how low it is.

hm even if it has nothing to do with win itself...can you look in your bios if theres an option which graphic slot is checked first? (something like onboard, pci-e, pci can be chosen there)
maybe theres something in your bios wrong o.O
[/quote]
I have the onboard video disabled.

Reply




Users browsing this thread: 1 Guest(s)