Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frustrating loss of performance with Win7 x64
#41
themanuel:
Just asking if you've already tried setting power saving to maximum performance.
The other modes may lower your PCI-E speeds to 1x.
(No clue if Microsoft or the GPU makers have fixed this by now but it was a problem once with Vista for me.)
Reply

Sponsored links

#42
I've played with that too and saw no changes, unfortunately.
Reply
#43
try changing your drivers. my default intel drivers let me go a full scale up in resolution in Okami compared to the 'latest' ones

EDIT: just read some more of your posts;


(06-02-2011, 02:44 PM)themanuel Wrote: Update on what I know, after many trials:

Soul Calibur III, in-game, Ivy vs Setsuka (or whatever):
- Win XP: ~80% GS
- Win 7: ~60% GS
- GeForce 8500 GT vs GTS 250: no difference
- Numerous GeForce drivers: no difference
- Different video plugins, DX9 vs DX10, etc.: no difference
- Video plugin set up for software mode: Win XP faster by about the same
- Other emus, for reference:
- Dolphin 32 bit: slower as well by ~20% in Win 7 vs Win XP
- Dolphin 64 bit: faster than 32bit in Win XP by ~10%
- Obviously can't compare Dolphin 64 bit in Win XP vs Win 7
- MAME 32 bit: exact same performance in both OS's
- MAME 64 bit: ~20% faster than 32 bit

I'm starting to get the feeling that the problem is with emulators that actually use the video card. However, the problem is not video card horsepower or the GTS would have made a difference. This must have to do with the way Windows 7 interacts with the video card. However, this does not explain why the game is still faster in XP when running the video plugin in software mode.

I'm starting to wonder if I should stay with Windows XP, but I need the extra performance of MAME64 in some games.


This seems like what I had. I think one of the explanations was that the way the components are split between cores on PCSX2 is assigned a core but, if one component demands full speed and the other doesn't (100%load/0%load) the CPU splits the load over two cores (50/50) even though the component still demands 100% from one of the cores.

I had the same problem with Okami which went from 2.8ghz to 1.2ghz in cut scenes. I'm on Windows 64bit. Its really weird but, nothing makes a difference except lowering the resolution, my CPU would run at full speed at native res but not anything higher.

start up cpu-z and keep pcsx2 windowed, and check the speeds you get
Reply
#44
(06-02-2011, 06:13 PM)rama Wrote: themanuel:
Just asking if you've already tried setting power saving to maximum performance.
The other modes may lower your PCI-E speeds to 1x.
(No clue if Microsoft or the GPU makers have fixed this by now but it was a problem once with Vista for me.)

its still a problem on x38 and x48 boards, and it seems the conclusion is that the boards are not reacting to power state flags properly.

Reply
#45
(06-02-2011, 07:10 PM)zanderman2009 Wrote: try changing your drivers. my default intel drivers let me go a full scale up in resolution in Okami compared to the 'latest' ones

....
start up cpu-z and keep pcsx2 windowed, and check the speeds you get

I have tried the drivers that Win 7 installs by default and the result is still the same as installing the nForce and GeForce drivers from nVidia for the motherboard and GPU.

Just in case, I'll check CPU-z while running the emulator to make sure the CPU is not being down-clocked in any way.
Reply




Users browsing this thread: 1 Guest(s)