GOW2 playable with videos?
I know back about 6 months ago when I tried to play GOW2, I got to the first seen with a god being roasted over a fire and the game hanging. I was told here on the forums that I had to disable all the videos in the game to make it playable.

Has anything changed in the last 6 months to play GOW2 with all the videos included?

Sponsored links

Nope, video emulation in PCSX2 has always been very buggy and that won't change for a while.
[Image: newsig.jpg]
in my case it worked very good. In the huge GOW1&2 thread we found out that frequently using save states is related to not playing videos, so use the ingame save system and you should be fine (NTSC version).

The one you described with the guy over the fire getting eaten by the bird day by day (what a freaky scene :/ ) was buggy for me too, but it can be skipped using the built in movie skipper in the patch menu. There was one other cutscene where i had to use the skip method but other than that everything played fine in my playthrough about a month ago.

I used beta r1888 with newer gsdx r2348 which has some new features and better compability over the standard one that comes with r1888.
I finished gow 1 and 2 about 1-2 weeks ago on r1888, ntsc. In gow 1 there was only one freeze in the end - well known white screen. In gow 2 I got 3-4 freezes in whole game, usually in end of video before switching to controls. Never used save states. Thats all and for gow 2 I used native rez., pity I didn't tried latest beta gsdx with scalers earlier ;( - playing now Valkyrie profile 2 using 3x without problem(beside first forest) thanks to it.
E7400 @ 3.6Ghz 1.33v, GTX-260 192SP 650/1400/1100/1.05v, 4Gb RAM, Windows Server 2008 x64
Ok sounds good guys. Looks like I should just start from a fresh install and try the latest beta drivers. Might just start from the beginning since I wasn't that far in.

Are there any updated GOW2 configuration threads?

Edit: Wow I can't even get past the opening FMV, what the heck?

Users browsing this thread: 1 Guest(s)