GS plugin not loading correctly?
I've been using PCSX2 for a while, and I just suddenly started having problems today.

I believe the GS plugin is not loading correctly, because I try to press F5 to change interlacing, and try configuring it inside the plugin config, but it's not actually changing. Games run fine though (just with interlacing issues).

I have tried every GS plugin I have (GSDx SSE2, SSSE3, SSE4.1, ZeroGS, GSnull) and all of them have the same problem. In fact, I had the "trouble loading plugin" error happening for a while until I restarted the emulator.

The only thing that I have fiddled with since last time was the resolution from the Config -> Emulation -> Window menu, but I have since changed it back to the default 640x480.

I have no idea what's going on nor do I know where to go from here. My specs are as follows:

i5 750, HD 5870, 4GB RAM, Windows 7 Professional x64

Please ask if you need anymore info. Thanks!

Sponsored links

Have you tried "re-installing" PCSX2? You could also try the new plugin pack, if you haven't already.
I'm at the most recent plugins available now. I just tried installing the new build (3119) and I still have the same problem. F4 and F6 still work, but I'm not sure if that's a feature offered by the GS plugin or not, but if so, it might just be F5 for some reason that isn't working...
What game?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Any game I try won't let me use F5.
Even if it doesn't let you use F5 for some reason then the interlacing options inside GSdx should work, so what games did you try and can you tell or take a screenshot of those interlacing issues? Cause not all games need interlacing to work fine so maybe you just couldn't tell.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Even when I choose the interlacing from the plugin config, the change doesn't carry over. I'm playing Atelier Iris and there are giant lines across the screen. Plus, I play a wide variety of games so me switching the interlace options is rather normal.

One thing I forgot to note, I've started using an XBox 360 controller recently; could that be interfering with my keyboard in some way? Keep in mind that F4 and F6 still work.

And I can tell what interlacing mode I'm in based on the title bar and I can see it's not changing at all.
Could you take a picture of atelier iris? That doesn't sound like interlacing.

You could try changing the APIs in LilyPad controller plugin. What settings do you have currently?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Yeah, actually, you're right, it's not an interlacing issue. However, the problem stretches beyond that single game. I'm not too worried about that specific case.

Playing with some settings, I managed to get something working. When I press F5 once, where it says "Interlace (None)", it'll change to "Interlace (Field)" but I can never get it back to (None), so I'm not sure if it's cycling through the options or not.

Thanks for the help Smile
for the pcsx2 spinning logo demo its "field" all the time...
for the ps2-bios its "frame" all the time.

boot without a disc/mounted iso into your ps2 bios (best testing environment, with me the ps2 bios is shaking as hell), fiddle around with f5, i'm pretty sure you will see the differences and determine that cycling through all interlacing-modes does work fine.
Intel 486 DX33 33Mhz
S3 Graphics Trio64V+
Windows 95
Running MGS3 Snake Eater fully playable @ 0.05 fps

Users browsing this thread: 1 Guest(s)