Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSDX: Hardware mode -  [Bug Report] Ape Escape 2 [NTSC-U]
#11
(11-04-2016, 12:00 PM)refraction Wrote: Can you try unticking large framebuffer and enabling hw hacks then enabling the Fast Invalidation hack, see if that helps.
Did this, enabling fast Invalidation hack did nothing, unticking large framebuffer made the framerate a bit faster underwater for 10s or so, then the drops happened again, and then they're gone, and back in 10s etc etc... Also makes my game crash if i try to pause it during a stutter i think, it can happen or not and sometimers i seem to be able to reproduce this everytime, sometimes it just wont crash, but it only crashed with these options.

(11-04-2016, 01:28 PM)gregory Wrote: But which mipmap did you enable ? Level 1 or 2 ? Level 2 requires OGL (and likely slow and broken).
I honestly don't know, i've just enabled SW mipmaps and HW hacks and then added UserHacks_mipmap = 1 at the bottom of the GSdx.ini file as a tutorial on how to use HW mipmaps told me to. I guess it's level 1 since the performance didn't change from 1.4.0 with no mipmapping.
EDIT: Was using level 1, tried 2, no change. There are some bugs with mipmaps but it's just HW mode not loading them progressively, resulting in sudden changes in textures when approaching, nothing to do with the problem described in this thread.

(11-04-2016, 01:56 PM)gregory Wrote: Oh. Broken mipmap can kill the perf. If the game set an invalid address, it could point to an old frame buffer. Data will be converted. Dx might do it on the CPU whereas OpenGL can do it on the GPU. Try to play with the CRC level. Note: the game can also uses some pseudo 8 bits frame buffer on purpose.
Already tried every CRC option, changes nothing.

Here's the dump: http://www.filedropper.com/gsdx20161104163920

EDIT: Just realized i forgot to rename the .gs file before uploading it, sorry, I would re-upload it but my upload speed is soooooo slow, if requested i'll do it.
Reply

Sponsored links





Users browsing this thread: 1 Guest(s)