Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSDX: Hardware mode [Bug Report] ICO [NTSC-J]
#1
# PCSX2 version: PCSX2 1.5.0-dev-1284 (2016-09-17)
# CPU options: Default settings, except VU0/VU1 Clamping at Extra+preserve sign
# Plugins used: GSdx 20160917 openGL & DX11 - Half pixel offset GS hack

# Description: Good work on fixing ICO's blur with proper custom resolution scaling, looks so much clearer now!
Just a (minor) bug I noted while testing is that hardware mode is missing the 'godrays' effet around some windows...
Not easy to spot on screenshots but you can see it more easily when switching from hardward to software rendering...
I attached a GSdump if someone wants to have a look... Wink


Attached Files Thumbnail(s)
       

.7z   ICO-godraysmissing-gs.7z (Size: 1,75 MB / Downloads: 38)
_____
Intel Core i7-5820K/16GB DDR4/GeForce GTX 960/MSI X99A Gaming 7 motherboard
...some of my PS2 games videos...
Reply

Sponsored links

#2
I can see the issue in your screenshots and dump, but it's not very clear. I played the game a little and found a great location to see the issue. Here's another dump:

[attachment=60994]

HW:
[Image: attachment.php?aid=60995]

SW:

[Image: attachment.php?aid=60996]
Reply
#3
CR ? Or standard upscaling
Reply
#4
The issue is not related to scaling. It's missing on native in HW. Wink
Reply
#5
Ok. I'm asking because CR doesn't handle well depth stuff. Hum, could you test SW without mipmapping ?
Reply
#6
Thanks FlatOut, I forgot I could move the camera up from below... the bug is much more clear on your screenshots...

>gregory
Just tested SW without mipmapping --> godrays are missing too
_____
Intel Core i7-5820K/16GB DDR4/GeForce GTX 960/MSI X99A Gaming 7 motherboard
...some of my PS2 games videos...
Reply
#7
Might be related:
fog effect is missing too around the castle in harware mode...

EDIT: fog still present in SW without mipmapping so that must come from something else... Tongue2


Attached Files Thumbnail(s)
       

.7z   ICO-fogmissing.7z (Size: 1,81 MB / Downloads: 29)
_____
Intel Core i7-5820K/16GB DDR4/GeForce GTX 960/MSI X99A Gaming 7 motherboard
...some of my PS2 games videos...
Reply
#8
I'm pretty sure I've seen the fog in HW. Might be fixable with a setting or it's a regression. I'll look into it.


EDIT: I didn't get to the tower, but went to a few outside locations and the fog was there. Can't really tell if the fog is missing in HW in the dump.
Reply
#9
I don't know if it's a regression either but the place with the first save point (the bench) has crazy flickering lights sources: the sky got some random darker garbage instead of bloom and the shimering bench gets randomly darker...

FlatOut, could you check this place too...?

EDIT:
Fog is also missing on the bridge at the same spot... (comparaison screenshot added)


Attached Files Thumbnail(s)
               
_____
Intel Core i7-5820K/16GB DDR4/GeForce GTX 960/MSI X99A Gaming 7 motherboard
...some of my PS2 games videos...
Reply
#10
@parotaku, check the CRC level, and be sure to use Nx upscaling.
Reply




Users browsing this thread: 1 Guest(s)