Thread Rating:
  • 1 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSdx Crash on Configuration
#1
With the later versions of GSdx (I can only get 846 to work, lol), it seems to crash if I try to configure, or use them. Though when using (Without any config) they run for a few minutes.

Essentially, I goto plugin manager, click the plugin I want, click configure, and it crashes.

I am trying to use GSdx 5442 (MSVC 16.00, SVE41) 0.1.16 [GSdx32-SSE4-r5442]

I am unsure if it's due to old versions installed, or what, I know my graphics card is up to par and latest update, my direct X is too, and I got c++ redistributable or whatever that's called.

Edit: As a note, PCSX2 crashes entirely. I first get a "pcsx2.exe has stopped working"

I hit Close the Program, then: the same thing again. So it does it twice?

Also, GSdx 846 (MSVC 15.00 SSE41) 0.1.9 works fine for some reason

My hardware specifications are:
Code:
------------------
System Information
------------------
Time of this report: 3/16/2013, 21:57:36
       Machine name: ASELLIA-PC
   Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130104-1431)
           Language: English (Regional Setting: English)
System Manufacturer: System manufacturer
       System Model: System Product Name
               BIOS: BIOS Date: 08/02/11 14:36:59 Ver: 08.00.15
          Processor: Intel(R) Core(TM) i7 CPU         950  @ 3.07GHz (8 CPUs), ~3.1GHz
             Memory: 16384MB RAM
Available OS Memory: 16376MB RAM
          Page File: 3518MB used, 13655MB available
        Windows Dir: C:\Windows
    DirectX Version: DirectX 11
DX Setup Parameters: Not found
   User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
     DxDiag Version: 6.01.7601.17514 64bit Unicode

------------
DxDiag Notes
------------
      Display Tab 1: The file nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um is not digitally signed, which means that it has not been tested by Microsoft's Windows Hardware Quality Labs (WHQL).  You may be able to get a WHQL logo'd driver from the hardware manufacturer.
        Sound Tab 1: No problems found.
          Input Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D:    0/4 (retail)
DirectDraw:  0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay:  0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow:  0/6 (retail)

---------------
Display Devices
---------------
          Card name: NVIDIA GeForce GTX 560 Ti  
       Manufacturer: NVIDIA
          Chip type: GeForce GTX 560 Ti
           DAC type: Integrated RAMDAC
         Device Key: Enum\PCI\VEN_10DE&DEV_1200&SUBSYS_35151458&REV_A1
     Display Memory: 4050 MB
   Dedicated Memory: 978 MB
      Shared Memory: 3071 MB
       Current Mode: 1920 x 1200 (32 bit) (60Hz)
       Monitor Name: Generic Non-PnP Monitor

Unsure if this contributes:
Code:
(GameDB) 9643 games on record (loaded in 175ms)
Path: C:\Users\Asellia\Desktop\pcsx2\Plugins\GSdx32-AVX-r5442.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Users\Asellia\Desktop\pcsx2\Plugins\GSdx32-AVX-r5442.dll
Path: C:\Users\Asellia\Desktop\pcsx2\Plugins\GSdx32-AVX.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Users\Asellia\Desktop\pcsx2\Plugins\GSdx32-AVX.dll
Path: C:\Users\Asellia\Desktop\pcsx2\Plugins\ZeroGS-OpenGL-Pg.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Users\Asellia\Desktop\pcsx2\Plugins\ZeroGS-OpenGL-Pg.dll
Path: C:\Users\Asellia\Desktop\pcsx2\Plugins\ZZOgl-cg-r5442.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Users\Asellia\Desktop\pcsx2\Plugins\ZZOgl-cg-r5442.dll
Path: C:\Users\Asellia\Desktop\pcsx2\Plugins\ZZOgl-cg.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Users\Asellia\Desktop\pcsx2\Plugins\ZZOgl-cg.dll
Path: C:\Users\Asellia\Desktop\pcsx2\Plugins\ZZOgl-r5442.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Users\Asellia\Desktop\pcsx2\Plugins\ZZOgl-r5442.dll
Path: C:\Users\Asellia\Desktop\pcsx2\Plugins\ZZOgl.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Users\Asellia\Desktop\pcsx2\Plugins\ZZOgl.dll
Reply

Sponsored links

#2
Banshou, why you start it from desktop? Make "emulators" folder on disk root and move pcsx2 there.
CPU: Core i7 3770K HT 4300Mhz
Mobo: MSI Z77A G43 bios 2.4
GPU: Radeon HD 6950
RAM: 16GB DDR3-1600Mhz
HDD: SSD Vertex 4 128GB, 2x Samsung 3TB
Windows 7 x64
Reply
#3
I've tried it in all sorts of folders, it's just how I organize my computer. It doesn't work anywhere.
Reply
#4
zzogl won't work on windows, AVX probably isn't supported by your CPU.
just use gsdx sse4.1 and it should be ok
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
As I said, GSDX sse4.1 wont work. None of the video plugins with 1.0.0 installer work, nor any of the ones with latest snapshot builds.

I can only use a really old version of GSdx without it crashing when I try to configure. I've tried 4.1, ive tried 3, ive tried 2.
Reply
#6
Do you get any crash with other plugin configs like the PAD or SPU plugin? Might be crashing when detecting the supported d3d version I suppose.

What's your current video drivers version? Make sure it's the latest.
Reply
#7
Pad/spu are fine, just those GSdx versions (the newest ones it seems). Tried a bunch of different ones.

My video drivers are 314.21, the newest.

I figure my direct X is updated cuz I used the web installer again, and I run farcry 3 and stuff, which installed newest versions.

I'm really hoping to get these working, I apologize if it's not enough information, I'll get whatever is needed. Perhaps something on my end (I did find about 300 C++ Redistributables installed, so I fixed that, and installed only the newest ones).

The older GSdx work (Mine says 890 I think, and 1.1.14), but, I'd like to use the newer ones as I figure they work better.
Reply




Users browsing this thread: 1 Guest(s)