Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[GSdx OGL HW] Borderless fullscreen ?
#1
Would it be hard to add something to be able to choose between true full screen and borderless (windowed) fullscreen in GS window settings?

Honestly I only ask because sometimes Nvidia messes up their drivers. For example while my ViewPortOut on my 720p Panasonic TV is 1215x680 after I correct the overscan with nvidia-settings (using nvidia-settings --assign CurrentMetaMode="DFP-1: 1280x720 { ViewPortOut=1215x680+30+20, ViewPortIn=1215x680 }"). However the recent driver now thinks I'm using true 1280x720 and mismatches the fullscreen window, so part of the screen is not visible. Worked great for years, then suddenly Nvidia breaks this behaviour in 361.28. A maximized window still fits perfectly on the screen, so to play in PCSX2 without cutting a part of the screen I'm now using a devilpie script:

Code:
(and (is (application_name) "PCSX2")
     (is (window_role) "")
        (begin
                (undecorate)
                (maximize)
        )
)

This simulates borderless fullscreen mode. I know I should really buy a TV which has overscan correction on the TV itself, but well, as long as things work I will keep using it.

So, thoughts on a borderless fullscreen option? Potential drawbacks?
Reply

Sponsored links

#2
GSDX already uses Windowed fullscreen borderless for "fullscreen" and has since .98
Reply
#3
On linux, it is already borderless. Otherwise it is a nightmare for me, debug of crash + dual screen.
Reply
#4
Ah ok lol, of course it makes sense that you were already using borderless.

Then I guess it means the new driver must be reporting bad resolution when you resize the window. Could you explain the method used to resize the window to full screen resolution ? It must be different from what I do with the devilspie script. It's not a regression issue btw, it's purely from my driver.

On my main screen everything is peachy. But on the TV it's not. I have a script I use to switch from main monitor to TV. It disables my main monitor, enables HDMI screen, corrects overscan, switches all running audio to HDMI and disables DPMS.

Code:
#!/bin/bash
SINK="alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1"
xrandr --output HDMI-0 --mode 1280x720 --output DVI-I-2 --off
nvidia-settings --assign CurrentMetaMode="HDMI-0: 1280x720 { ViewPortOut=1215x680+30+20 }"
pacmd set-default-sink $SINK
for i in $(pacmd list-sink-inputs | awk '/index/{print $2}'); do pacmd move-sink-input $i $SINK; done
xset s off -dpms

ViewPortOut = 1215x680+30+20
ViewPortIn = 1215x680 (it's set implicitily)

[Image: VtWj0IQLnQxnzFaE.png]

So the driver should report to PCSX2, hey, your fullscreen window should be 1215x680.

But now in this new driver, it's saying, hey make it 1280x780. So when I double click to set PCSX2 window to fullscreen, I have part of the screen cut off. As you can see PCSX2 window is 1280x720 while desktop is 1215x680:

Code:
[[email protected] ~]$ wmctrl -l -G|grep EE
0x020000c5  0 0    0    1280 720  riverdance Slot: 0 | Speed: 101% (60.48) | Limiter: Normal | GSdx OGL HW | 2048x1792 | Auto | Interlaced | EE:  50% | GS:   8%
[[email protected] ~]$ xrandr
<snip>
HDMI-0 connected 1215x680+0+0 (normal left inverted right x axis y axis) 1434mm x 806mm
   1280x720      50.00*+  60.00    59.94  
   1920x1080     59.94    50.00    50.00    60.05    60.00    50.04  
   720x576       50.00    50.08  
   720x480       59.94    60.05  
   640x480       59.93  
At least I assume it's a driver issue. Or else it's Xorg 1.18.1 or something. Rolling release distro like Arch is sometimes no fun Smile I don't know, it would depend on the method you use to set the window size.
Reply
#5
The window is managed by the library wxWidget. And then, I guess the fullscreen is managed by the window manager itself. For PCSX2, fullscreen doesn't really exist. Windows users got also strange behavior with the Nvidia driver on the fullscreen/borderless.
Reply




Users browsing this thread: 1 Guest(s)