GSdx Scanline Question
I've been playing with the scan-lines option available in the GSdx_FX_Settings.ini file (I know very little about shaders so I've stayed out of the shader.fx file). Basically I'm trying to get some clean scan-lines since most of my library is 2D, and while I have had some success, I'm trying to figure out why there appears to be a gradient being applied (see below).

[Image: Gradient.png]

Without scan-lines this is a completely white background. But as you can see, with scan-lines it get's a little darker then a little lighter repeatedly down the screen.

Anyone know why this happens or how to fix this?

Sponsored links

The only time i've seen this is if the GS window isn't the right size (i had this in a personal dx project), so it ends up clumping pixels closely together, generally in 3 bands too.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
That's a known issue, I'm afraid - for now at least. I had to do a slightly wonky algo as a work around for gsdx scaling issues (type 3). (scan lines are typically best used at native resolution).

Scanline type 0 shouldn't have this problem. But, it may not work as well with high scaling - so, if you're using a low/native internal resolution, you can switch to type 0 and play with the settings a bit to get your desired effect. Please be sure to read the option descriptions as a guideline for defaults etc.
Currently I'm using the native resolution. I'll give scan line mode 0 a try and play with it a bit. Thanks.
That happens to me too but I prefer the shader.fx more compatible.
The only time I use the gsdx_FX settings is when I enable bilinear filtering because it actually smooths out jaggies. I just press F7 and use the much nicer scaline filter
Yea, try to use the ones on F7. They're working differently and will prolly give you nice results Smile
FYI - if you use the current SVN, the f7 scanline shaders will now save your selected shader. Instead of reverting to disabled every time.

Users browsing this thread: 1 Guest(s)