[GSdx] Tokyo Xtreme Racer Zero [NTSC & PAL]
This game is now working with r5732.

For those of you who are tired of driving around with crappy looking ZeroGS, there is a temporary solution.
As we all know the game crashes after the intro with the GSdx (stuck in limbo or whatever). The trick is to skip the intro and avoid loading menus.

You will need:
GSdx (or ZeroGS)
Save states

Method 1:
Emulation settings -> GS -> [Check] Disable all GS output. Load the game and wait until the menu opening menu theme. Save state! PCSX2 will freeze no matter what now. Task Manager -> [kill process] pcsx2-rxxxx.exe -> Start PCSX2 again and [Uncheck] Disable all GS output. Load the game and the load the saved state. Enjoy.

Method 2:
Don't use GSdx and play with ZeroGS instead. Enjoy.

The menu is broken completely with GSdx, so have fun navigating it! Smile

Sponsored links

I'm just going to clarify the bit about other games getting more attention.
We're basing this entirely on whether someone in the team has the game in question
and then whether we feel like fixing it.
I know no one has this title, so it's going to be an issue if we can't even look at it.

That said, I suspect a resource issue with GSdx. Read the guide to find out how to enable the skipdraw
hack and try this.
Alternatively try software rendering.
what's the internal resolution of the game. I've seen a screenshot from bug reports. looks like the interlace ***** on DMC. I think I could butcher a progressive hack for ZeroGS (again -.-).

but don't count on me. I hate doing things like that and I'll have to todo it from scratch and blind. no d/ling.
xstyla, the games native resolution is 640x448 I believe.
good to know.

it reads like it's a abit iffy. sure bad this' a rare case game only fully working on ZeroGS with minor issues.

devnote: if there're more of them, that would open an option for the GameDB to switch those rare cases to ZeroGS. and maybe find someone to fix bugs like that. not that I.........

meh. cheers to the Xmess. lazy XD

Updated and put a guide in the first post for those who are interested.
Seems to me that it's just a minor bug. Problem with loading menus, nothing major broken.

Tried to record a video using XSplit showing how to do method 1. However, the game crashed no matter what when attempting to use "Disable all GS output" to get the opening menu. I had to turn off XSplit before the trick would work. Very strange.

Note: Crash as in the loop problem after the intro.
Try using the Skip mpeg hack in game fixes to see if it helps you with the menus/intro
[Image: newsig.jpg]

Every single fix/trick has been tried to make this game get past the intro, nothing helps. Unless you have the dvd / iso, don't waste your energy. This game needs a patch I guess Smile

Users browsing this thread: 1 Guest(s)