Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSdx crash
#1
I updated my Fedora Rawhide to latest as of 18/07 and pulled master from git and made a clean build from it.

Then when I went to try and launch my test game it crashed after the intro. Software mode worked fine. It also crashed ingame when I used software mode to get there, and then changed to hardware mode. I use the radeonsi driver.

I've attached the emuLog from after it happened.

Edit: Haven't tested older version yet.


Attached Files
.txt   emuLog.txt (Size: 23,09 KB / Downloads: 281)
Reply

Sponsored links

#2
You should run proprietary graphics card drivers. Make sure you also have the 32 bit proprietary driver libraries installed as well. Did you compile a release build? I run into unhandled segfaults in debug builds all the time, it's a glitch with SIGSEGV handling (pcsx2 has it's own handler for SIGSEGVs for reasons I won't get into). If you've tried all of those things and GSdx hardware mode still fails, you can try running pcsx2 in gdb and issuing
Code:
handle SIGSEGV noprint
before running pcsx2. This will cause all unhandled SIGSEGVs to be silenced. It might fix it.
Reply
#3
Hum, there is no symbol on the trace. Did you strip the build, or maybe retry with a dev build.

It is likely an issue with the GPU driver.
Reply
#4
The old one doesn't work either, so it might very well be the GPU driver.

Also the build is just standard from build.sh.
Reply
#5
for sure it is related to driver. In the trace there is LLVM, which is the GPU compiler (because we don't use llvm on PCSX2).
Reply
#6
Are you using the Mesa drivers for your video card? The reason that I ask is that I was getting a similar crash when I was testing recently with those drivers. The workaround for me was to go into the Advance settings for the GSdx driver and set 'Seperate Shader' to 'Force-Disabled' (I also had to set Geometry Shader to 'Force-Disabled' due to some video corruption issues)
Reply
#7
Hum install mesa dbg package (i386). On my system
Quote:libgl1-mesa-dri-dbg:i386
libglapi-mesa-dbg:i386
libegl1-mesa-dbg:i386

It will allow to have the symbol in the backtrace, therefore it will help to find a correct solution.
Reply




Users browsing this thread: 1 Guest(s)